How Do I Make My Mesh Not Blurry?

Hello I had to go back and start over on my mesh. But this time the stencil brush is blurry. Not sure why. Last time I did it the end product was crisp. Does anyone know what settings I change to obtain that crisp look I had? See screenshots for details please.

https://paste.pics/846IS

Thanks

Bump. Can anyone please help?

The image texture on the right has a lower resolution. For a crisp face you should have at least 2048x2048 pixel.

I tried changing that and it didn’t make it better. :frowning:

that’s the difference i see, maybe you changed the mapping

How can I check for mapping settings that I accidentally changed?

I would take a look at it in the uv editor. if you still have both files just open both of them then you will find it faster.