how do i make the screen not focus around the origin

i am pretty new to blender and 3d modeling and still learning stuff everyday. every time i try to navigate around to get a better angle to model, it rotates around the origin. it hasn’t been a terrible problem, just really annoying to work around. i was just wondering if there was a way to move the screen i see horizontally or vertically, without rotating around the origin, similar to fly mode with the camera. Thanks in advance for help!

You can use fly mode (I think we’re calling it “walk mode” in the most recent versions because some functionality has been changed) without the camera. Or you can focus the view on a selection with the numpad . button. Or you can Shift-MMB-drag to move the view. There are a number of ways to move the center of the view, depending on what exactly you want to do.

you can also set the viewport to rotate around your cursor position in the User Prefs.

As said above using SHIFT + MMB can pan your view side to side/up/down.
And hitting decimal key (number pad .) will recenter your orbit around that active selection. Using these two moves can get you pretty much anywhere you need.

Walk mode [email protected]#$s. That is the first thing I change in my default on a new install. Change it to ‘Fly’ mode. Walk and Fly are different modes and Walk is now the new default, it used to be Fly. So it is another thing you have ot change to make viewport navigation acceptable.

Also I change the Orbit style from Turntable to Trackball. With trackball your mouse position in the viewport determines how the view will be rotated when you rotate the view. Click and drag near the center for a more object centric rotation and click and drag near the edge for a more bolder move.

is there anyway to do that without MMB, as i am on a laptop

I dunno. I’m not a fan of the WSAD navigation of walk mode, but WS does seem to be a little more precise for moving in and out than mousewheeling, at least on my mouse. YMMV I suppose.

You can use Alt+LMB if you turn on Emulate 3 Button Mouse in the Input settings. But, as a tip, get an actual mouse for your laptop. Using a trackpad will severely limit your growth as a 3D artist, and will cause countless headaches.