How Do I NOT Animate?

I am a beginner at messing with 3D objects. I am using Blender v2.7 (the latest version as of this post).

I downloaded a rigged .dae character and posed her. Once you pose a character, exporting them as an .obj should always export them in that pose. however I cannot seem to do that.

I searched these forums and there are MANY tutorials on how to export a rig as an animation. I don’t want her animated. I want her as a static object for a passenger in a car in a game.

Blender appears to not be able to do this I suppose, but I want to make sure I didn’t just miss something before I start researching paid software . . .

Steps I am taking:

  • Downloaded a free rigged model from the net.
  • Posed the model
  • Clicked File->Export->Wavefront .obj file
  • I have the following selected, which is correct: Apply Modifiers, Include Edges, Include UVs, Write Materials, Objects as OBJ Objects

PROBLEMS with the export:

  • When I import the obj, she is back in the default T-Pose again, so her pose is not saving
  • Her UV maps are NOT exporting, as I am only getting an obj and mtl file. The textures should be exporting also.

Is there another program i need to be able to successfully save this as a FROZEN model? From what I am seeing, Blender is for animation, not static models.

Blender is for animation, not static models.
Just tried with a simple rigged object, exported as .obj, imported it and it is as expected in the correct rigged shape.

Supply a blend file with the object in its final rigged form, the exported .obj file and you blend file with the object re-imported

Works fine here, too…
And btw, .OBJ does not “export” texture files. The .MTL file contains the paths to the files (looks like this):

# Blender MTL File: 'Juliet_Saeko_BI.blend'
# Material Count: 4

newmtl MI_CH_Main_Juliet_Cloth_Cine_Cos01
Ns 0.000000
Ka 0.000000 0.000000 0.000000
Kd 0.640000 0.640000 0.640000
Ks 0.000000 0.000000 0.000000
Ni 1.000000
d 1.000000
illum 1
map_Bump D:\\Data\\Characters\\Juliet_Saeko_Busujima\\Texture\\TX_CH_Main_Juliet_Cloth_N_Cos01.tga
map_Kd D:\\Data\\Characters\\Juliet_Saeko_Busujima\\Texture\\TX_CH_Main_Juliet_Cloth_D_Cos01.tga
map_Ks D:\\Data\\Characters\\Juliet_Saeko_Busujima\\Texture\\TX_CH_Main_Juliet_Cloth_S_Cos01.tga
map_Ns D:\\Data\\Characters\\Juliet_Saeko_Busujima\\Texture\\TX_CH_Main_Juliet_Cloth_S_Cos01.tga

... and so on

Is it possible to have a model that cannot apply the data? I did download this from a site called Maximo. I’d link you but you won;t be able to view the page as you have to have special software installed on your PC to view the web page, so it is not possible for you to view the page directly. however I will provide the file I downloaded and the blend I imported her into:

ORIGINAL FILE:
http://faelandaea.com/custom_files/blend/export_issue/Mia.zip

RIGHT AFTER I IMPORT HER INTO BLENDER:
http://faelandaea.com/custom_files/blend/export_issue/Mia.blend

By the way - for some reason I am not sure if it is lighting or what, but I cannot see the textures on her when I have her open by herself in Blender, yet when I import the original model into a scene I already have created, her textures come up fine. This is obviously my setup as the model is very high quality and has no errors. Anyway, continuing on . . .

POSED BLEND JUST BEFORE EXPORT:
http://faelandaea.com/custom_files/blend/export_issue/Mia_Sitting.blend

I then go FILE->EXPORT->Wavefront .OBJ, select Apply modifiers, Include Edges, Include UVs, Write materials, Objects as OBJ Objects (this is the correct sequence per tutorials from this site). This is the result:

http://faelandaea.com/custom_files/blend/export_issue/Mia_Sitting.obj
http://faelandaea.com/custom_files/blend/export_issue/Mia_Sitting.mtl

I am starting to come to the conclusion that my current Blender setup cannot save frozen states as it is not applying the filters. Also, when I attempt the export, my Blender snaps back to her starting “T” position, and I have to press CTRL+Z to get her pose back.

I can’t open the files at the moment but as a simple option, select your model and apply the armature modifier. This should fix the mesh into the posed shape and you can delete the armature

To ensure image texture files are found by the .mtl file I usually find the following usually works
Save your blend file
Pack all textures into your blend file (File / External Data menu) so they are all collected together
Save your blend file
Unpack all your textures (File / External Data menu) so they are all now in a single texture folder that the .mtl file can reference
Save your blend file
Export as .obj file
Open the .mtl file to check it is using the correct directory for your textures.

I keep seeing tutorials that say to do that. unfortunately pressing CTRL+A then hitting SHIFT+% doesn’t work, and that is what people are saying to do to supposedly apply the modifier. Of course the only tutorials available are dated in 2010, so hot-keys may have changed since then, but I doubt it.

You have keyframes on that armature, which will completely override you pose mode settings…

In Pose mode:
a) Hit A to select all bones.
b) Switch to animation screen layout (top of the Blender screen, next to Help, where it says “Default”).
c) In the upper left viewport (Dope Sheet Summary) hit A to select all and X to delete.
d) Now you can pose, export and save her without the pose resetting.



Oh wow! I had no clue all that was in the file. i thought I was just downloading a rigged character to pose. THANKS!!!

That did the trick for exporting as an OBJ, but something Richard said peaked my interest . . . something about applying the pose and then being able to delete the armature. Right now my procedure is:

  • Import game vehicle
  • Import character
  • Scale/pose character in vehicle
  • Delete vehicle from scene
  • Export character as obj
  • New scene
  • Import vehicle
  • Import obj I just posed
  • Assign mesh files to appropriate nodes in the model
  • Place obj as desired
  • Apply location and rotation
  • Apply parent transform
  • Export model

If i can figure out how the hell to do what Richard said, it’d knock out half those steps!

Apply the armature modifier by pressing the Apply button in the modifier panel
http://wiki.blender.org/index.php/Doc:2.6/Manual/Modifiers/Deform/Armature
http://wiki.blender.org/index.php/Doc:2.6/Manual/Modifiers

Note that when you apply it you will not be able to use the armature to repose the model, that’s why you may see reference to not applying the modifier. If you don’t want to pose the model further then who cares if you apply it. The Apply Modifier option in the obj export settings does exactly the same as you pressing this button but only as part of the export process

Yeah I saw that article before. Unfortunately my interface does not have that button:


You have the armature selected, you need to select the posed object. This is also what you need to select when you export as .obj with the ‘selection only’ export option enabled

Okay the posed object is 5 meshes in the screenshot. BodyGeo, Eyesgeo, HairGeo, LashesGeo and teethGeo. i selected all of those one at a time and also tried selecting them all at once. There is still no Apply button.

Nevermind I see it. I had to click the little wrench, even though in the screenshot on the tutorial you linked me to they do not even have that in the picture. I’ll gibve this a try and let you guys know how it turns out.

Getting so close. Okay I got her posed, and I exported, but the game went whacko when I tried to load the vehicle. Total texture confusion. So I started looking at her meshes compared to the rest of the mdoel’s meshes - she has something called “Vertex Groups”, and it will not let me delete them.

Is there a way to convert or get rid of these vertex groups? I think they are confusing the game.

In the linked tutorial http://wiki.blender.org/index.php/Doc:2.6/Manual/Modifiers/Deform/Armature I see references to this but . . . is it too late now to go back and try to get rid of these since I already applied the armature?

… and, y’know, there are some aspects of the UI design these days which aren’t entirely intuitive. Such as, for example, the fact that certain buttons do not exist in a list-of-buttons unless an Armature is selected, or you are in Pose mode, and so on. These are things that, sure, you “learn about” quickly-enough, as you do with any complex and sophisticated software tool, but they can very easily “pitch you off the bus in the darkness without a ticket” until you do learn the trick.

I do understand the tradeoffs that are inherent in such a tremendous (and, overall, IMHO tremendously good) user-interface design challenge such as Blender presents. I do understand why the buttons were made to come and go. I’m not saying that it was the wrong call to have made. But, “hold tight to your ticket!”

SOLVED!

I dunno - once i got as far as i did in post #13, I just selected her meshes, exported her as selection only as an obj, and then reset Blender to bring her in as an obj and redo her again. Once i did that she sort of straightened up in game. Only issue now is she looks great in Blender but the game is seeing odd spaces/tears where her joints are, but that I will figure out later. I haven;t slept yet and I need to before today’s appointments. I’ll try again tonight to perfect this all.

By the way, this is all to get a passenger into a truck for Euro truck Simulator 2. I am not sure if anyone is even familiar with that game but I used to be a texture artist in the modding community and recently took the dive to start modding objects and accessories into the game.

It’s called context.

Don’t clutter the scene with tools that you cannot use because you don’t have the right type of object selected. Armatures cannot have modifiers so there is no need to show the modifier panel. Object don’t have bones so why show the bone properties, or curve properties, or lattice properties or bone constraints. etc etc.

This is a simple basic logical concept you need to grasp

I agree with Richard.

My issue was not that the button wasn’t there. My issue was I was kind of a victim of freedom and options. LOL Yes, I know that sounds wierd, but look at it this way - Blender gives us a LOT of freedom and a LOT of options to customize our layout. The drawback to this is that every person out there - and i do mean EVERY one - writes their tutorials so you have to follow their setup. Even when you open a .blend file, your interface rearranges itself to the layout of the person that wronte the .blend. That’s why I only download .obj and .dae files to work with.

My particular screen setup is also the result of tutorials I am following. I use Blernd2SCS, because I am modding for Euro Truck Simulator 2, so my Blender’s startup file is set up to the tutorials that are teaching me exactly how to attach imported objects and models to that game. Then I got the Lynda.com series to try to learn Blender better - different layout - etc.

Do I disagree with these options? No. In fact i LOVE that we can rearrange as we see fit and only have what we want to work with on our screens. If i show frustration while pursuing a learning experience in these forums, it’s my own frustration at trying to understand instructions someone else is giving based on how their layout is made, but we all get frustrated at what we do not understand sometimes.

Which brings me to the original reason for this reply - a huge THANK YOU to the guys who replied with patience and understanding and helped me resolve this issue. I only have one more roadblock I encountered to finish this learning experience, but those appointments I had to sleep for - I need to get to them - so I will reply here tonight with screenshots of what I am seeing and an explanation of my steps. I tried asking in the modders forum for ETS2 but the replies I got there were that I was doing something wrong as a modeler working with Blender and not int he game itself, so they bounced me back to these forums to get help. I am hoping between Richard and Ikari and whoever else might be able to help that I will finally have a workflow for this, as once I have a RELIABLE workflow, I’ll be able to start getting better at this.

It is my hope that sometime soon I’ll learn enough to be one of the ones helping others on these forums . . .