How do I remove this "mottling" on this metal plate?

I am rendering out this metal plate.
I increased the anisotropic lelev in the shader and I like the look now.
However, there is mottling on the plate. How do I treat that mottling?


Full shader:

Looks like a denoising issue. You have only 500 samples for your render. I’d recommend no less than 1024. Anything with reflections needs far more samples.

1 Like

I’m still getting that mottling with 7k samples.
I wonder if its to do with the scale of the noise or something else?


I see you’re using an image texture. Maybe the problem is in there? Try to play with your Texture Coordinae and Mapping nodes. For an example, you can try to do next things:

  1. In Texture Coordinate node, switch from an UV to Generated,
  2. In Mapping node, switch Type from Point to Texture,
  3. In Mapping node, change all scale axes values down to 0.1

I am pretty sure that the problem with your textures coordinates and thus it can be solved by changing texture coordinates or/and its sizes

Almost forgot, also try to play with mapping Location values.

  • Denoising takes the color textures into account when processing an image to avoid blurring details out of existence. However, roughness and metallic textures are not taken into account in this process, so if you have details that only exist in those maps, denoising might mess those up. The solution is to plug the roughness texture into the color slot too. You can pass it through a color ramp and make it just barely have an effect on the color: as long as it’s there at all, it will help keep the details intact.

  • It looks like the metal is reflecting something that’s extremely noisy. What is the rest of the scene like? That is a lot of noise for 400 min samples and it looks extremely uneven.

Ah, looks like a low res image then. If the texture is seamless you can simply increase the three size factors on the Mapping node. If the texture is not seamless, than you’re going to have to do it procedural (which is a better option anyway).

You can raise the samples to a million but without changing the Noise Threshold too, you’re going to get pretty much the same result. Once the Noise Threshold is reached, sampling stops.

1 Like

This helped a lot!

Switching to Point was good.
@etn249 - I’m not sure what you mean " plug the roughness texture into the color slot too" - which node into which color?
In the rest of the scene there are no other objects.

I might try and search for a better brushed metal material.

Current (shadows under knob still poor):

1 Like

I mean like this:

Right now, the color ramp is doing absolutely nothing, as nothing is plugged into it.

By plugging the roughness map in the color ramp, you can reuse it as a color texture. At first, it will likely look too intense, but you can adjust it by modifying the 2 colors of the ramp. Give the material a subtle color and it will be picked up by the denoiser and the details will be kept much more intact.

1 Like

I gave that a try, it helped a little*.
I think the root cause is the resolution of the brushed metal texture. Anyone got a recommendation on where I can get a good hi-res brushed metal texture?

Like this?

1 Like

It might be not just the resolution, but also the texture filtering setting. On the image texture node, you can see a setting that says “linear”. That’s the texture filter. On a low resolution texture, you should try setting it to “cubic”, which is a higher quality setting.


Glad it helped you!

BTW, you can try to download that texture in more higher resolution, like 4K or something. It could’ve helped, but I’m not sure.

1 Like