How do I stop a background casting it's color onto objects?

Hi! Here is a render of an object on a colored seamless background. How might I stop the color of the background from casting onto the model? You can see the screen housing is absorbing a lot of the color from the backgrounds. Thank you!

1 Like

Also any general lighting / material tips accepted!

Hi Stewart, welcome here. Nice one. I would just suggest to bevel its sharp edges slightly.
If you really want to deactivate the light interaction with the ground, under Object Properties - Visibility, theres a subsection Ray-Visibility. Its just there if you render your image with cycles. There you can deactivate diffuse and glossy rays, so that they re not reflected. You have to do set this on your ground plane.

1 Like

Hey @stewartsc !
What is the background ? An object like a plane / cube or something like that or it is an environment texture ?

Alternatively, you can use the lightpath node to change the objects appearance in glossy reflections and diffuse bounced light.

Yes it’s a plane.

Hey thanks! It’s not the shadow the object casts I want to remove but to reduce the amount of pink color that bounces onto the surface of the computer object.

Super helpful! Dank u Kyron!

1 Like

Yes I think I got you right. By deactivating these two checkboxes it should do exactly that.

1 Like

You can go in the object properties, while selecting your plane (background), and uncheck “diffuse” in the ray visibility

unchecking :


checking :

2 Likes

Thats what I told him already. :grin:

2 Likes

oh crap :dizzy_face:
I’m so sorry, I didn’t even notice :no_mouth:
sorry for that :upside_down_face:

2 Likes

No, really no problem. As it seems he got me wrong and your images show it very clearly, so :+1:

1 Like

Yeah I misunderstood the original reply. Thanks both of you! Very much appreciate you sharing your time and expertise.

1 Like

Follow up question if ok? It looks great on the render preview but still renders with the diffused light from the background plane. Is there another setting I need to change for the final render?

Sure, is that ok, but no there is no other setting needed for that. I mean there are several things that cause the preview to behave slightly different to an explicit ( final ) render, but not for that setting. :thinking:

If its possible for you to upload it, we can have a look at it.

This is the preview. Looks great with no blue casting onto the CPU.

This is from the render.

I meant, if its possible to upload the blend file. Sorry for being so unclear. But perhaps thats not even needed. I see you have multiple groundplanes in your scene. Did you change all invisible Ray visibility settings for all the ground planes? Because hiding just hides it in the viewport not in the render. That might be the reason for the difference.

In blenders outliner there is a visibility setting for viewport and a separate one for render.
That render visibility toggle can be activated on top of the outliner( filter button at the top right).
You have to activate the filter for render-visibility in the filter toggles, to make both settings directly editable. Be aware that you have to setup both of these settings for viewport and rendering separately.

Or you use a free addon I’ve written. I can automatically sync viewport visibility and render visibility.
So if you install it and set it to autosync, then using the eye icon in the outliner would be all you’d have to setup for visibility. The addon takes care to sync the settings directly before you trigger a final render.

Ahhhh that makes sense. I’ve found myself deleting ground planes temporarily in order to render. Anyway here’s the blender file. Don’t judge! I’m still learning lol

Can’t seem to upload an attachment because I’m a new user but will give your extension a try!

1 Like