How do I stop a Mask object having reflective properties?

How can I use an object as a mask but not render it as a reflection (on other objects nearby)?

I have a building in the foreground that should mask a UFO behind it. But when I make the building’s material Transp:mask it still reflects against the UFO. The same thing happens when I move the building object to another layer (reflections cross layers).

It would be great to have a DON’T cast reflections option in the material. Just like shadows. Can I stop layers affecting each other?

Didn’t know if this was a materials issue, sorry.

Hmm, well have you tried rendering them in different layers?

can you upload a sample file so we can see what you mean here!

and some pic to show this effect


happy 2.5

would still be interested to see a sample file to see this effect and other people might find it interesting also

happy 2.5

what do you mean by mask

is it like another texture layer use as a mask?

happy 2.5

Material transparency: mask. It passes alpha matte shape or sky. Good for using as a matte shape when compositing over real objects.

uncheck “tracable” in the Material objects, if you ment the material of the mask object itself, uncheck “ray mirror”
just made a tutorial on transparency:

Oh, cool. thank you very much.