How do i stop my textures from stretching?

UV mapping

If you do your scaling within the edit mode, you can use the “Correct Face Attributes” option to avoid stretching the texture.

1 Like

I dont see that

You’re using the 2.9 build…it should be there. Try doing a quick search on “Correct Face Attributes”, you might find out what is missing.