How do you customize realtime text in 2.63?

Hey guys. I know how to create a custom font texture for the old-style realtime text (pre-2.63), but that text doesn’t seem to work since 2.63. It looks like I need to create an actual font file (.ttf, .otf, etc…). Does anyone know if that’s possible using just Photoshop or is there a free font creator/editor that you can point me to? How do you guys create custom fonts for 2.63?

Or if there’s a way to simply apply a texture to the text, that would work. What I want is letters with a fire texture and a thin black outline.

…Ok I’ve been playing around a little.

There is a Texture Space panel under the Font tab, but I must not be understanding it, because I can’t get it to apply a texture to the font. Maybe that’s not what it’s intended for or maybe I need UV coordinates, but I can’t find a way to setup UVs on a text object - I don’t think it’s possible.

I tried creating a material with a texture, but I believe text objects always get their color from the object color under the Object panel.

I think I’m gonna have to use the ‘blender object as font’ option. I should be able to use planes with simple alpha textures for the characters. The good thing is I only need the numbers…for now. I’ll see if it works…

If anyone has better ideas/options, your input would be appreciated.

I usually get a font from a free commercial font site and just use that. I haven’t really tried to make my own font. I don’t know if it’s possible to apply a texture to a font itself - I’m not 100% sure of how you would do it.

Thanks for the reply, SolarLune. It looks like I may have to go that route because I’m at a dead end. I followed the documentation (see below), but I can’t get the ‘blender object as font’ option to work.

I’m using planes for the numbers (I’m only doing numbers 0-9) with a UV-mapped texture. They are named properly - I even named them pretty much exactly what it says in the documentation (ft.0, ft.1, etc…). I have the Vert duplication option selected on the font object. I’ve played around with every setting I can think of, but it still just displays the original Bfont.

Maybe numbers don’t work? Or maybe this feature isn’t operational. I think I’ll have to start looking for an appropriate font online that I can just use. Or I suppose I could go back to 2.62 and use a bitmap realtime font, but I don’t really want to go back :no: