How Do You Make Blender Startup On Correct Monitor?

I have 4 monitors. 2 top are using a crappy NVIDIA Quadro card.
Bottom 2 are using GeForce 550 Ti.
I don’t know how this happened but Blender, by default keeps opening
on the upper left monitor. It is set to use the GeForce video card (bottome monitors)
and I have tried saving default scene, ui, etc while it is on the bottom monitors.
but it still keeps opening on the upper left no matter what I do. How do I get it to
open on my main monitor like all other apps do. Or at least to open on the last monitor
it was used on (like all other apps do)?

Please, may the right person view this post.
Such a stupid, tiny, simple thing, but it’s really growing to annoy me hardcore.
I re-installed to the latest version. It worked like normal for the first 5 or so
startups, but now it’s back to opening on the upper left monitor.
Never in my entire life of Blender usages have I run into this issue.

Maybe I’m alone on this issue.

You are not alone - but did you figure it out?

This sounds more like an OS problem than a Blender problem, have you attacked it from that angle?

I wouldn’t mind seeing an answer to this one, I had a 4 core on twin monitors win7 basic, built a new 8 core put win7 pro on that one same graphics card and monitors but now both blender windows always open on the 1 monitor arrrrrrrrghhhhh why???

Use nVidia’s “nView Properties” application to set programs start-up on muliple monitor setups.

Right Click Desktop --> nView Properties


http://www.digital-air.co.uk

I’m not knowledgeable enough to say if that’s what it is. But it does not seem likely since out of the hundreds of installed programs Blender is the only one that does this.

Right Click Desktop --> nView Properties

Thanks ardee I will try this as soon as I get back to my work computer.

Move Blender to the monitor of choice.

Go to the File menu and select: Save Startup File

Make sure you don’t mouse off the tiny dialog window that opens for confirmation.

Click the confirmation.

Now it should start where you want it to.

Thanks for the advise, but that’s the first thing I tried and it did not work.

I’m a little hesitant to use the nView app since it is specific to NVIDIA Quadro video cards.

if its windows… i would suggest “display fusion” , it has options to set up each program on your pc… you can do kewl stuff like, having different desktop backgrounds on each monitor… all the usual junk, but for me its very useful for stretching blender across two screens as it saves the window location and size, as well as the active monitor. so on starting blender , i have it stretched across my screens like you could do by hand…

(I also have the windows and viewports “fit” nicely, so i have a large 3d view and a timeline / action editor on the left screen, then a smaller 3d ortho view on my other screen with the properties window, image editor and curve editor and whatever else i might need on the right screen) hope it helps… it was the same problem i was having for a while.