How do you reassign the Hotkeys?

I went to user preference, changed the default F12 hotkey to F1.
So that I can get to the button faster.
But when I click save as default, and press F1, nothing happens.
When I try to press F12, nothing happens! I have to reset everything!

Could I get some help please?

F1 is probably already taken by “Open Blender File”

If you go to the “window” section of the preferences and uncheck that,(or make that one F12)
then your F1 render command should work.

Just switch Open File and Render keymap keys.
you can only have one action assigned to a keymap,