How do you seperate your animations?

Right now i have my animations set after each other in different times on the timeline. It’s starting to get really confusing as i have to constantly adjust my timeline to preview lets say animation c between frame x and frame y… I google around for the action editor thing in blender. I was wondering if others here use the action editor as-well? And what things i should look out for etc. Generally i really need help having control over my animations without having to adjust the timeline every time. One other major problem with my current method is that, for every new animation i have to keyframe every single bone in a rest state. And this makes my dope-sheet huge and confusing. Really curious how for instance the animators in “Sintel” and “Cosmos Laundromat” did it. Or of-course the hidden professionals-hobbyist animators, inside blenders community !

Are you using the dopesheet set to “action editor”?

I do a lot of animating for modding, which requires a lot of looped sequences.Without actions things would get messy very quickly. It allows me to store each animation as a separate sequence that I can access from the drop down list.

Although I don’t use it much, I could if I wanted to, organise them in the NLA editor too. Giving me the option to extend and mix them if the project called for it.


Yes you use the Action Editor, Which as stated is a sub section of the Dopesheet. Create a bunch of new actions, copying your original animation and name them accordingly to your animations. Then delete the keys that shouldn’t be in that action. You edit each animation independently. When you want to link them together you use the NLA editor. :slight_smile: The “F” button on the action editor is a must, it keeps your animation if not linked. DO HAVE THE F (fake user) button toggled on, or you will loose all of your hidden animations!

I had been doing that religiously up until I started using 2.76. But as you can see from the image, some of them weren’t tagged with a fake user. Despite the fact I’ve edited and saved that file hundreds of times.

I wouldn’t say don’t bother linking to the fake user though. Because as soon as I do, they’ll probably disappear. :smiley:

I did a quick nose around. It looks like the actions got stashed automatically by not having a fake user assignment. The stashes I have in the NLA editor match the unmarked actions in the image above.

This must’ve been added as a fail-safe at some point. I just wasn’t aware of it. But it sounds familiar and would explain why they haven’t vanished. I assume once you add a fake user, you could clean out the stashes, if you felt it necessary.


Macser and thedaemon ~ Thank you both so much. This is EXACTLY what i need. I have been clicking around and things got a bit confusing with the dropping down and stuff like that in the editor. I love your last screenshot. it looks so organized. Thats exactly what i am trying to go for. Hopefully i can find some detailed documentation or video to further explain. Since you mentioned possible losing or fail-safe words. it gets me a bit anxious haha! Thank you guys so much. Btw that meg rig looks awesome Macser!

oh and wow thedaemon just went to look at your blog. that animation panel and everything looks very useful! awesome work you are doing there!

I’m having a couple of problems though.
#1 My shapekeys are hard to find in the action editor. i am trying to delete them so i can move my frames back to 0 without shapekey actions.
#2 When i delete shapekey frames. it stays in the values they were in. + My entire action editor seems to shrink back down to 1 frame.
(While the timeline is showing all keyframes that should be there)

Steps i took:

  1. Since i have a full timeline of about 24 animations, i made 24 copies of this entire timeline in the action editor. And named them (walk, wave, sit, etc)
  2. Then i went ahead and cut out all of the bits that are not needed for every action i created. so that i end up with just those pieces of frames in them.
  3. I then wanted to move them back to 0 on each of these actions. But thats where the shapekey mumbo jumbo starts to happen. The shapekeys dont join in.

The reason i make full actions of full timeline is because i could not find a button that does “Create action from current frame range” If the button is there it would be awesome.

More things i tried inside action editor:

  1. Tried using the home button but that did not work.
  2. Tried pressing “i” to show all channels. still no shapekeys.

The shapekeys are clearly showing in the curve editor though… strange!

I’m not very experienced with shape keys outside of using them for mesh deformation. So thedaemon might be of more help there.
Have you tried the shape key editor in the dope sheet? I know you can give them keys in there. Which should allow you to manipulate them directly like you do with actions. But like I said, it’s not an area I’ve explored much.

The rig above isn’t very complex. Just the necessary bones to bind to the mesh, and some controls to make things a little more manageable. Done very quickly. The hard part is creating all the animations to go with it. :slight_smile:

What was mentioned about the fake user assignment is true. Up until recently that’s exactly what would happen. No fake user tag meant the next time you loaded up the blend, there was a good chance your actions would be missing. It seems the action stashes were added to counteract this. Like many people I’ve been caught by that a few times. Especially when you get into a good session, where you’ve got a large amount of actions. But the action stashes act like a safety net. So far at least.

Well thinks sure are starting to get frustrating now…
I gave everything a fake user. And saved my blend file.
when i re-opened. my character looks fine…
But as soon as i open one of the actions.


my character deforms into a snake like creature lol…

Also it seems that the action editor is not holding all information.

That “mangling” of the mesh usually happens when you try to select an action that’s associated with another object. I’ve often done that with a camera action while having my rig selected. The results were a mess. Selected the rig and choosing an action linked to it sorted it out. :slight_smile: