How do you smooth out curves [created from GPencil strokes?]

Hi there!

So GP is a fantastic tool, though it seems almost unusable as it appears as a bunch of straight lines put together… right?

Or may I create, or modify GP strokes before conversion, somehow?

Thanks a bunch for your reply’s!

You can edit the mesh and use the Smooth sculpt stroke

Hmm… when I use the smooth stroke, the manipulators appear [on the the vertex/point] and therefore I am only able to move/etc that single point and not really smooth out all the points…


More info about grease pencil stroke sculpting

Hold E pressed then try to sculpt.

Nope, all of the instances (from Smooth to Clone) act as ‘Grab’, so I am only able to move one single point… holding E does not make any difference…


Then you are doing something wrong.

Ensure you are using the latest blender version.
Supply a screencast showing exactly what you are doing and supply blend file at the point you are trying to smooth the stroke

Sure. Updated Blender.

Deafult cube/scene>Tried drawing both onto a scene (Cursor placement) and an object (on a surface)…

Still no good. Just dragging points around…


gpencilsmoof.blend (443 KB)

I see there is no answer for a while…

Assuming you try out using mouse:

  • On T-pane Sculpt Strokes, bottom - uncheck Affect Pressure.
  • In your last image, what do you see if you press F key or Shift-F? Do you see adjustable size and strength circles?
  • If you’re able to see them - press E key and LMB (assuming you haven’t screwed default shortcuts somehow). While still holding LMB let go E key and draw over jaggedy-jag Curve segments (does matter if they belong to Scene or Object; you have to select needed on N-tab Grease pencil -> buttons Scene or Object ).
  • C key will bring up selection circle and you’ll be able to select curve points on currently active ( belonging to Scene, as in example file) curve (Shift-D to duplicate selection, G, S, R).

Does it work now?

Hold E pressed then try to sculpt

Thanks, did not knew that, with me is working. Explanation seems missing from the manual.

Guess i’ve dug E-key somewhere here in development threads.
Thank you, nice to know my rant was of some use ;).