How do you stack boxes ?

How can you stack boxes and have them not jiggle when starting ??

Simple answer: Use 2.40 and switch to Bullet Physics in the F8 window.

Complicated answer: If 2.40 can’t be used for whatever reason, then increase mass, form, and RotDamp of the boxes to soften the effect.

did all of that in 2.40 They still bounce, there seems to be no way to get thgem to sit on top of each other. either they are inside of each other or outside and start falling on each other and bounce when game start… Can you provide an example file if I am messing this up please :smiley:

Uh…well, have you put a material on everything? (Materials lessen bounce) And how are they laid out at the beginning? (read:screenshot)

Here is an example file.

Click Here to download Cube Physics

errors in downloading it

File ID is not valid

  1. Do you use ‘bullet’ physics?
  2. Did you try the demos in the latest build?

Download this file (linux)
http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=blender-2.40-linux-armaturesShaders.tgz

Or the Windows version with Samples:
http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=blender-2.40-GEplus.zip

Try to run jenga7 or physics animation baking demo. do the boxes in those demos jiggle too?

Erwin

Yes they do…

That’s the first time I hear so! What machine do you have?
Is ‘enable all frames’ set?
Are you just joking?

Hmmm enable all frames does change the play of it… Why ?? Any way
http://s49.yousendit.com/d.aspx?id=30VMT0JNPFDQT0VQ01W1QCI01V

This test file still bouncces… Why I dont want it to bounce, This file will explain, http://s17.yousendit.com/d.aspx?id=3E61WYJRA0I0U0BEKB1DY91BS9 I need that to sit pretty untill I press a key to activate the destruction meshes… Otherwise there is no way to get it to look clean with out all sorts of hop washing in Affter effects…

I made one without bounce, but it ain’t valid or somthin. Lemme host it onto me site.

Increase the “Form” value as well, will help QUITE a bit.

it’s at 100.00 already in the example file I posted…

Is there not a way to say script the postion of objects as still life on start and only become physics enabled on keypress?

Still I would need the rock settings but it would avoid the jiggle at the start and the on keypress would get the action going while this start moveing and the whole jiggle would be avoided…

cause since I was deadlined I did not get to use the game engines physics for the project half and had to do it all by hand… what joy! :<

Sorry for being so late.

Here it is.

CubeTest (Right-Click Save-As)

It is just a matter of perfecting the Form, Damping, Rotation Damping, Friction, and the “Bouncyness”. My example isn’t perfect, but I didn’t spend much time on it, only around 10 minutes.

hmm file seems corupt, you can try yousendit.com it’s free to send stuff and easy

youngbatcat, I have a similar problem.

Im using 2.40 (bullet), and when I try to stack one box on top of the other, the box thats on top actually bounces way up.

It all works fine though when I have them just drop down independently (side by side). In this scenario bullet physics do great, but I still cant get around the stacking problem.

Sorry I was not more helpfull, but at least I bumped this very (at least I think) important topic.

This is probably well known. But it hasn’t been mentioned so I’ll add it.

Have you cleared any rotation and reset size? With bullet in 2.4 you will get odd interactions if this isn’t done. If you don’t know what I’m talking about check out the release notes here:

http://www.blender3d.org/cms/Bullet_Physics.724.0.html

Hmmm enable all frames does change the play of it… Why ?? Any way
http://s49.yousendit.com/d.aspx?id=30VMT0JNPFDQT0VQ01W1QCI01V

This test file still bouncces… Why I dont want it to bounce, This file will explain, http://s17.yousendit.com/d.aspx?id=3E61WYJRA0I0U0BEKB1DY91BS9 I need that to sit pretty untill I press a key to activate the destruction meshes… Otherwise there is no way to get it to look clean with out all sorts of hop washing in Affter effects…[/quote]

First of all, the testfile is using Sumo, not Bullet.
Secondly, the physics is not properly setup. It uses convex polytope interpenetrating and mixed with other objects without even bounds.

It will take time to get used to seting up the collision shapes properly…
Perhaps first try with a small test?

Bullet stacks boxes, sphere, cylinders, cones and convex hulls. Did you checkout ‘jenga7.blend’?
Can you share a simpel blend that show the problems?
Erwin

Ddid you set bounds to box?