How do you start a rigid body simulation at a certain frame?

Hey!

I am wondering if it it possible to start a rigid body simulation at a certain keyframe. I have looked up several tutorials about cell fracturing and the shards are always “held in place” by rigid body dynamics. if you check “enable deactivation” and “start deactivated”, the shards get activated by a collision withanother rigid body object (e.g. like a bullet or a ball hitting a window).

I cannot animate the “start deactivated” button, which would have been the easieset way I thought of.

However, I do not have a collision object like a bullet but want to start the shards falling at lets say keyframe 100.

Is it possible doing this without the game engine? I found this tutorial but am too much of a noob to do it:

I guess I could just add a “invisible” rigid body object that collides the window at a certain keyframe to trigger the simulation but wanted to ask if there was an easier way.

Thank you for reading!

oh, I forgot one thing: of course I tried animating the “animation” checkbox at the rigid body type settings. The problem is that I can’t copy those settings from the active shard to the other shards. And I’m too lazy to individually keyframe every single shard. :stuck_out_tongue:

Here’s a blendfile to show what I mean.

You want to keyframe the Dynamic checkbox up at the top of the rigid body settings. Turned on means the object participates as a rigid body. Off means it doesn’t. If you want to animate the movements of the object yourself for a time, you can also keyframe the Animated checkbox next to it. Animated checked on means you are in control, not the simulation.

1 Like

Hi K Horseman
thanks for your reply! :slight_smile:
Unfortunately, this does not seem to work for me, since I have a lot of shards.
I can control a single shard with this method but somehow I can’t apply the keyframed checkbox settings to all the other shards. (I could do manually, but they’re too many).

I guess I’ll take the noob path and just go for an invisible collision object and get over it :smiley:

But thanks again, dude!

Hi,

Properties > Scene Tab > Rigid Body Cache, you can set the frame_start and frame_end of the rigid body simulation.

Tried this with your file, by setting start to 100 and nothing drops until the sim starts at frame 100. Is that what you are after?

Hey,

yes it is! Thank you so much for taking the time, I’ll try it! :yes:

And it works :smiley: Thanks dude!
I don’t know how to mark this thread as solved, but it is :slight_smile:

Is there a way to copy this key from one dynamic object to another? I can’t get them to show in the dope sheet because they have no animation on them other than physics.