How do you stop tiling of materials in the 3D view

This is from a closed thread that had no answer:

I have set a UV texture to use on a material. The texture image is much smaller than the unwrapped mesh, so by default, it tiles the image. On Texture Buttons (F6) on the ‘Map Image’ panel there are 5 buttons to set what happens if the image doesn’t match the image space. I have ‘Clip’ selected. It is working perfectly when I render the image. But the 3D view is still showing the texture repeating itself as if the ‘Repeat’ option was selected.

I’ve been wondering about this for years.
Is there a solution?


What I sometimes do (maybe not the best option) is that I assign a different material to those faces where the texture is needed,unwrap them separately and apply that specific texture to that material. This way the rest of the mesh stays unaffected,but this results in a higher number of materials (which doesn’t really bug me since I always name them properly).

I had everyone try to do this at Siggraph.
None of the Blender guys could make it work.
They suggest that this is a long overlooked missing feature.
The problem is that the uv’s are being driven in the viewport from the wrong data.
They aren’t being pulled from the object properly. It should be an easy fix for a dev, and it would make Blender work like other 3-D packages.
You should be able to adjust your uv’s and see them in real-time in the viewport with GLSL properly.
You shouldn’t have to render to see the placement.