how does one install a python scipt

hi,
I have an xp windows with blender 2.42a I have been having trouble with using scipts. I have no idea where to start even. I’ve seached and have become more confuesed that before I started.
If someone will please (I’m down on my knees asking) post a step by step of how to get scripts to work with blender on xp that would be wonderful.

I’ll assume a default install here.
1.) Copy your .py scripts to here:
C:\Program Files\Blender Foundation\Blender.blender\scripts
2.) Launch Blender create a scripts window by converting the default 3D window to a scripts window or splitting the window.
3.) Click on the ‘Scripts’ menu item and your script should show up there. You can also refresh the menu list if you copy scripts into the folder while Blender is already runnning.
You can also create a ‘Text Editor’ window and do a file open to browse directly to your script.

And, I might add that

  1. If you have trouble finding the Blender scripts directory (this is located at <blender install dir>.blender\scripts), you can run the System Information script (Help->System->System Information…). The full path will be under “Default dir for scripts:” (you’ll need to know how to use the text editor).
  2. You can create a directory of your choosing that holds all your “custom” scripts. Just add that directory to your file paths (for help on user preferences, click here). Make sure you save your preferences by hitting CTRL-U.

Levi

I am having the same problem, even after installing python.

I have put the scripts I needed into the scripts folder, split the menu, and updated and they STILL don’t show up.

I have no clue what Im doing wrong, please help.

redteam_spartan: I don’t really have a clue what’s going wrong. Have you ran the System Information script (Help->System->System Information…)? Is the directory listed under either “Default dir for scripts” or “User dir for scripts” the same one you put your scripts into? Are you sure you’re looking in the right menus for them?

Levi

Goto Start >> Run. In the popup “Browse” to your Blender folder and select the Blender icon and it’ll load the file path. Add “space -d” to that (whatever/blender.exe" -d) then "Okay to run it and Blender will fire up. Look in the console for errors. If what you see in the console makes no sense to you copy (rightclick the header bar) and paste it here.

%<