How I can reduce the noise?

Descriptio: Cycles 6000 samples - 6 hours. Somebody can give me a tip how I can reduce the noise in this escene. I was trying with the global illumination, but anothe clue? thanks.


You should fake the lighting scenario, because relying on a single lightsource shining through a small window requires a lot of bounced light to properly light the scene, which requires a lot of computation.
Try to get rid of the glass in the window so you can turn on “No caustics” which will get rid of the fireflies. To get back the window, you will have to render them separately and combine them in the compositor. You’ll probably have to do something similar with the curtains too.
You can put mesh lights (planes) on the inner side of the window (with the color you would expect from the outside) to get more light inside. Set the ray visibility so that it’s not visible to the camera and so that it doesn’t cast a shadow.
This should let you have enough light to dial back the number of samples.

Looks great! im sure conner made the points that will be really useful. Thanks conner

Hey there
I think you should be able to reduce the amount of noise by changing the material of the glass to this:


I quickly made a test scene a while ago when I had the same problems with nose and glass as you have now.
The first picture shows a UV sphere with a bit of thickness to it and a normal glass shader. In it is another sphere with a emission shader.
The second picture is the same scene with the same amount of samples and everything else unthought but with the node setup I mentioned earlier.



Or if that dose not work there’s a great tutorial by Bartek Skorupa on removing fireflies with bilateral blur, you could check out.
http://cgcookie.com/blender/2013/02/…positing-node/

Anyways I hope this was at least a bit helpful :slight_smile:

Martin

Thanks for your help. In the windows there is no glass, I will try with the mesh light, to know the scene can improve a little more, thanks again.

It only works in specific instances (sometimes it makes the edges of things a bit odd), but when it does work well it reduces noise like a boss. It might be worth giving this node setup a try: The file and node setup is in the description.

Luis here you have the node/blend you see in the video
i had to recreate it as the link in youtube is dead,
just download to your PC and open YOUR blend and activate the passes like in the image :


from the file you download APPEND/ NODETREE to your scene/file
then render lets say with 1000 samples and use the node in the compositor
You will see it really works, but CAUTION its not working good with glass!

Thanks for your answer. There is the final render, in this scene the lamp sun is null, and I have added two planes emission from each window and a little of post production in photoshop. I hope the staff of blender work in a future in this aspect “the noise from the the lamp sun” - sorry my english is bad.


I love this scene, very realistic. You have worked very well with the wood. But I like everything. Have you modeled most of the objects there?

Regarding noise, I think you should “first” try to reduce the noise with good lighting and good materials and render settings.
If that does not work, post production/compositing. But that last image looks very well. Have you used 6000 samples again?

Saludos!

i like this image, wonderful admosphere, and technical problems of noise very good resolved.

fine archviz

has Cycles got bidirectional pathtracing already?

Awesome scene, well done with the noise!

Hi @LuisVoronov. Your render is great, but I think there is a lot of noise on the walls. You can set clamp, in render panel, option to 9 or 10, and also try to set another emission plane behind the camera, with its strength lower than the other emission planes. Sometimes this will help to you to light dark corners, although the light has a low strength, and remove noise.

Spanish: Hola Luis. Tu render es muy bueno, pero creo que todavía tiene ruido en las paredes. Puedes poner la opción clamp del panel render a 9 o 10. También puedes intentar poner otro plano de emisión de luz detrás de la cámara, con la strength más baja que los otros planos de emisión. A veces esto ayuda a iluminar rincones oscuros, aunque sea con poca intensidad en la luz, y quita ruido.

amazing atmosphere , i like your render very much.

@niebieski,
I do not understand your Node-Setup. (bilateral Gaussian Blur Node.blend)
Where is the Image-Input?
A little tip would be nice!

You don’t use the image. You must delivery all the render passes and you use those to compose the image.
@niebieski, thanks for sharing that complex node setup.

@Dito : its a node setup i recreated from the video JohnatanL link us to.
its not my own , i wish.
The node dont use image from the source , just connect all sockets and it works great. not glass thought.

@brujo : you welcome , you sure do nice complex nodes , im just a copy cat.

I found an error in the node setup…

Edit 2 : yeah i screw up the names of the sockets …

@elbrujodelatribu and niebieski,

many thanks for your answers.
But this Node-Setup doesn’t work for me.
(Also the updated one)

But this from Jonathan L works.
http://www.pasteall.org/blend/25031
(The link was broken yesterday)

one of the really good works here. It’s very realistic and also a very interesting scene, for me the first render looks even better than the second, because it has more contrast. the noise gives it kinda the look of an old photo. How the light breaks through the curtains, amazing. i have to try something like that, too :stuck_out_tongue: