How i make my character stay on the grass?

How i make my character stay on the grass?
I have pic:

can you be a little more specific?

Two suggestions:

  • Turn up the gravity
  • Check the size of the character’s collision boundsFrom the image provided, I can’t tell the exact problem, but one of these solutions should work.

maybe he forgot to check the dynamic button?

It might be to do with the bounds of the landscape itself, check the settings.

There is a constraint actuator, It would work to keep your character from falling off the sides of your level if that is what you are aiming for.

It may even just be the bounds of the character. Play around with the settings, man. If you haven’t checked the bounds box and picked something, by default, it’s a sphere. Then change the size.

this thread is like 5 days old but you didn’t post if it fixed it

Or if you’re using linear Velocity to move gravity don’t work.

and if none of these help you how about a .blend?

oops sorry, i didnt fix it i dont know how to fix. The bounds didnt help

It will be the bounds,
post a .blend so one of us can sort it for you.