How on Earth do I composite footage with 3D Objects?

I tracked a scene using Voodoo, imported the script into Blender, and now I want to Compose my 3d mesh with the footage. But I can’t.

I use an alpha over node, but then my 3d mesh just gets transparent. I tried every possible tutorial, and I do not get the the results following the tutorials are supposed to give: Which is to place the Image/Movie sequence in the Upper part of the Alpha Over Node, and the Scene with my mesh in the lower part/input to the Alpha Over Node.

[ATTACH=CONFIG]232256[/ATTACH]
(EDIT: On the picture above I tried fiddling with the inputs, I tried both, none works).

But the cube is showing on to of your footage in the composite node, isn’t it? It’s a little small, so I can’t really see it.
In the shading tab of your render options, did you check to set your alpha to “transparent” instead of “sky”?

  1. I use Cycles, so I don’t have the Shading panel in my Renders tab.
  2. Even when I do use Internal, it still behaves this way, even after setting Sky to Transparent in Shading panel.

Cycles has the same transparent option in the “film” tab.
Can you load up a larger picture of your composite node? It looks like the cube is on top of your footage correctly from the tiny image in your screenshot. You could also enable “backdrop” and link the alpha over to a viewer node. From the screenshot it’s hard to tell what’s going on.

Try one more time with alphas set to transparent in cycles (film tab) and then connecting the render to the lower socket of your alpha over. It looks like the background of your render is grey in your screenshot, which is usually an indication of the alpha set to sky.

Thank you. That worked :slight_smile:

Great, glad it helped =)