How stop Extrude on Z axis

When I extrude it is set to extrude on the blue line, the z axis. I would like to freely extrude. I know you can hit z to cancel after you start the extrude, however when I extrude the next time it always comes back. How do I stop this?

its not extruding on the Z axis, its constrained to the face normal usually so you can extrude directly without misaligning the face.

you could hit space and find “Extrude Region and Move”. Now when you hit spacebar again you can do it again. But have no idea how to create a shortcut for that or a button…
Would be nice to have the option to disable that “autoconstraint”… but realy don`t need it often.


you could also hold “ctrl” an click somewhere in viewport to extrude to that point.