How to active Z-buffer in Game Engine

When I try for instance to display 2 overlapping Cubes, they appear as overlapping in the 3D view but when I launch the Game Engine, they seem to be sorted face by face, as if the per-pixel Z-buffer was not working.

Is there an option to enable to make it works properly?
Is it the same problem as the alpha sorting one I have seen around?

See attached .blend file to reproduce the problem.



ZBuffer-Problem.blend (242 KB)

I finally solved my problem: It seems that there is a bug in blender 2.47 when performing the UV Unwrap of an object. I don’t know exactly what goes wrong, but the problem is no more present with 2.48 RC1. :slight_smile: