How to add a background image to a render?

  1. So I click the world tab
  2. I click Use Nodes.
  3. No nodes appear in the shader tab.
  4. Ok, whatever.
  5. I click Image Texture for the background.
  6. I select an image.
  7. The entire background turns a color from my image.

Why doesn’t the image appear centered on my camera in the background, regardless of where my camera is? Is there some scaling or centering I must do and if so where do I find it?

NOTE: I’m not trying to do an HDRI. This is just a plain, flat image with a perspective that I’m matching.

EDIT: Ok, you have to choose Camera Data in the Vector option… but even though I’ve enabled the Extend option above it, it doesn’t extend. It’s stuck in the upper right corner. Why is that?

First .to see your world node you have to change the node interface from object to world. Up Left.
And you ve to change the word texture coordinate plugged in your texture to… screen

for efficient flat background you need add “images as plain”