How to assign texture to my object

I have a floor and would like to assign texture to my floor. The following are my steps:

a) click on texture icon
b) Under type I select image/movie and select my image

However, the image seems to only visible at the texture property as shown at the right side of the print screen. My floor is still colourless and lifeless :no:. How can I assign the texture at the property to my floor ?

Attachments


Assuming there is nothing else missing, the texture should render when you press f12. if you want your textures to show up in your viewport, you have to change the viewport rendering to glsl (in the properties panel under display) and change the shading mode to textured.

hope this helps

Jo5ef. Thanks if I were to assign a texture from image, it work but if I were to use the rest of the texture, I still have problem to assign. The following are the summary of what I have done :

a) Select the object in edit mode / viewport --> textured
b) Go to texture properties / Type of texture --> I select stucci / Basic --> Voronoi F4 (the image is as per the properties but it fail to reflect in the object). I can’t use the image editor to assign the texture because it is not an image.

Questions :

  1. How to assign the texture
  2. How to add colour to the texture (right now it reflects black and white only)


I

Attachments


The basic steps to add a texture are
Select your object
Add a material to your object
With the material selected add a texture to this material
Map the texture to whatever influence you require such as color
Press F12 to render
If you want this texture to show in the viewport you need to be in textured view mode and set GLSL display. This will only work for image textures, for any of the procedural textures, you will have to bake them to an image (Render Bake settings) then apply this image to your material

Richard thanks. it works when I press F12. But how to set GLSL display?