How to bake multiple textures into one including alpha channel?

Hello everyone!

I know there’s plenty of threads like this but none of them included any information about baking textures with transparency (or at least I couldn’t find one). On the screen below I have 3 cubes with different materials which I want to bake atlas from, where the middle one uses transparency which is not included in normal baking. How can I add that transparency to the baking process? Here’s what I’m doing so far:

  1. Attach textures to each cube
  2. Use the Texture Image with transparency on the middle one in the alpha channel and then set the Blend Mode to Alpha Clip
  3. Create a second UV channel for each of them to bake
  4. Unwrap all the cubes with Smart UV Project
  5. Create a new Image for baking purposes and with Alpha channel checked
  6. Create a Texture node that I want to bake them to and set it to each of the cubes
  7. Bake in Cycles with Diffuse Bake Type and only Color selected in the Contributions.

This process allows me to bake the atlas but it doesn’t include the alpha inside of the texture… How can I make it transparent?

The image:

I’m really scratching my head hard over this one as I couldn’t find any tutorial which includes the transparency baking…

Cheers!

Hay, Thanks for this question… I was just thinking about how to do this and after a quick search I found this tutorial on Baking…go to about 12:00 to start of the alpha section…

Then you can combine the Diffuse Texture with the Alpha image in the Compositor for a single texture image.

Thank You for the reply. Unfortunately I can’t bake alpha with the video example. It just goes fully white instead of pointing out the transparent pattern. Perhaps I do miss something… I’m actually a newbie to blender so it’s very likely. Here’s all the info I can provide I guess:

I haven’t tried as yet but set it to Direct, indirect, and color…and after the bake open the image in the image editor and check the alpha channel…

Sorry, I just noticed…

Ok…You still need an object to bake to…
A simple way is to add a plane…Add a new Material to the Plane…add a new texture image to the Plane ( select your Bake Target Image for the texture)
Select the Cube and Shift Select the plane…
In Bake settings…Click on Selected to Active…
Bake

Inside the Grid box you see is another Cube , slightly smaller…I just hid it to show the Transparency of the Grid-Cube

It’s so shameful for me but… It still doesn’t work. I did what You told me to, I did create a plane, added new material to it, I did set the Image for it, I did unwrap it just to be sure, I’ve selected the cubes and the plane as the last one and I did check Selected to Active option. Perhaps I still did miss something, but the result is in the screen below (and by result I mean an empty bake).

Try disconnecting the Image Node from The Principled and make sure it is the only thing selected

Did you pack the UV’s in the UV editor? I see you are selecting all 3 cubes…
If it fails again…can you send the Blend file? and I’ll see what’s up…

I did pack them as You can see below:

And yeah… It still doesn’t work so I will just send You the file and I hope You will be able to find the solution. I really appreciate Your help so far!

Here’s the file: https://drive.google.com/file/d/10ji5g71F8wvAoKZZ48DJOqGB98jpx5_I/view?usp=sharing
(As a new user I cannot upload multiple objects at once, hence I gave the link to gdrive)