How to Change Background Color in Cycles? - Blender 2.65

I’m having a bit of a mental block here - Using Blender 2.65 and the default background color is Megenta when rendered. I put a video as a texture for the world space, but everything just ends up that default Magenta.
I have attached a pic to show what I mean:


Yes, I am a huge Doctor Who fan so I thought I’d model his Tardis.

As you can see in the pic I am on cycles and I have the node set up for the world texture. But my background is still magenta, and the glossy bits are reflecting that instead. Boo to me :frowning:

(a side note: Ideally, I obviously want the video to be the source of light and be reflected by the glossy bits, but I will settle for just finding out how to change the magenta to a less intolerable color!)

Update to the latest version 2.66a that now supports movie textures
http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.66/Cycles#User_Interaction

If you want to us a background texture you can also use a transparent background and use the compositer to incorporate you object into the movie.

Thanks Richard for the quick reply. I’m def going to download 2.66. I was probably going to render over transparent and do compositing in After Effects. But out of curiousity, what if I just wanted the back to be solid black, or blue etc? Where is the color picker is cycles to change the background?

Render / Film, enable Transparent tickbox to give a transparent background for use with a image format that supports transparency.
To make the background black set the background material strength to zero

Richard mentioned how to render with transparency. if you want a solid colour, disable the transparency option, in the world node, delete the image texture (or remove the connection by dragging one of the sockets out) and the background node should have a colour input visible now, click on the white box and the colour picker should appear

Thank you Richard, that’s a HUGE help!
:smiley: