How to copy and paste objects and their collection folder structure?

Hi. I seem to have got myself a little stuck with a large project.

I’ve recreated a large boarding school from pictures with quite a few buildings, swimming pool, tennis courts, football fields, large main entrance and numerous other things. Unfortunately the whole blender model has got that large everything is now slowing down, screen freezes or blender crashes so I thought I’d copy each building and paste it into its own blender file so I can work on them individually and then when all good copy and paste that back into the main blender file. No problems with the copy and paste but I realised that when I pasted the building into its new individual file I lose all the collection folders and everything is just dumped together.

I’ve spend hours creating collections with their own subfolders so I can access a particular object quickly such as window frames, drainpipes, roof areas, doors etc. and it’s pretty grim seeing all that lost and everything all mixed up during the copy and paste.

Is there any way I can make an exact copy in Blender 2.93.4 ?

Thanks for your time,

Andrew

Make a new file and append the desired collection from the main file. It should have all the sub collections and sub objects intact.

Delete those items from the main file.

LINK the collections from the other files back into the main file.

Thanks for the quick reply. Appreciate it.

I managed to do the first append and have a new blender file with the correct collection and its subfolders underneath of a building. It’s all greyed out though and there’s no model visible in the viewport but I’m guessing that has something to do with the linking you mentioned?

I deleted those collections that make up the building from the main blender file so there’s no building visible anymore but can’t quite understand the linking part. Could you please explain further please?

Hmmm… I’m not sure. If you select an object in the outliner and press decimal button on your numpad does the view move over to where the object is? Is your original scene very big in scale/area?

Hi Thinsoldier.

I’ve been trying all sorts to get it working and found something hidden

  • I have a new file open in one instance of Blender and also the main file open in another instance of blender.

  • In the new file I go to append and then find the main .blend file and then into the ‘Collection’ folder and choose ‘chapel’ folder (the name of the building)

  • Wait a few mins and then see the chapel collection folder has been imported with all its correct sub folders but all greyed out and no model chapel in the viewport.

  • By accident I right clicked and saw Visibility and then ‘Enable in Viewports’ and bingo there was the chapel

So I have the chapel building in the new file and it’s correct Collection folder structure so that’s great news :smiley:

Not too sure what these parts mean though

Delete those items from the main file. (I can do this part)

LINK the collections from the other files back into the main file. (How to do this and what is the purpose? Will it update the main blend file automatically when I make changes to the model in the new file?

Thanks again.


Now that each building is in its own file, you can have a main file where you assemble the final scene by Linking in the various buildings from the other files. You can make changes to the buildings in their own files and then when you open the main file again it will read those changes and show them in the main file.

Instead of breaking up everything to different blend files, have you tried to just inactivate the collections you don’t want to work with at the moment? That should speed things up.

Wow! That’s absolutely fantastic and many thanks for the information on how to achieve it thinsoldier.

The amount of time I’ve spent looking at that small blue rotating mouse cursor while blender is trying to catch up with an object I just rotated or another change. It’s been awful. My blender model covers quite a large area and weighs in at 1.6gb in filesize. Then I added 60% of the vegetation which consists of trees, bushes, Graswald grass, and the size jumped to 17gb so pretty heavy I guess. This is my first large model so nothing to compare it with and I’ve only learnt things as I go along and need them.

I have a fair amount of booleans for windows and doors and noticed that in the main file that assembles the final scene, after I link to the single building file and it appears in the viewport the cubes that act as the booleans are all visible and no way to hide them so they don’t render as invisible. Strange as the building in the single file has them hidden and set to not render.

Ztreem, thanks also and yes I did that quite some time ago. It did help but everything is just way too slow which is a shame as I have a good updated pc now with a Ryzen 9 5950X 16-Core Processor 3.40 GHz and 64.0 GB ram but the GPU is only an RTX 2060 so I render with CPU and works fine.

Now I’m going through the process of making sure all objects are in the correct groups to Append which will take a while but worthwhile.

Here’s a link to the project with just 3 X 360 degree renders. The final project I hope to have a tour of 20 X 360’s.

https://cicadastudio.com/virtualtours/wbs/

Worked out the issue. You have to actually apply all the boolean modifiers and then delete the objects that were used for the boolean cutout. Now I have a building that looks correct with door and window holes.

I guess I always wanted to make everything still editable in the future and that’s why I never fully applied the booleans but am happy to now so I can have this Masterfile with linked blends setup.

Thanks for all your help with this.

Cheers,

Andrew

There should be a way to keep the boolean modifiers intact. I suggest doing a reduced test case file to see if the same behaviour happens when you’re only working with a handful of cubes.