How to create a "portable" Blender 2.8 on Mac?

I typically ask users who are having problems installing KIT OPS (or any addon for that matter) to download and create a portable version of 2.8 and test the addon there. It requires creating a config folder in a specified directory as outlined in the video below:

My question is does anyone know how to do this for Mac? Users are telling me it doesn’t work, but since I don’t have a Mac, I can’t test. Any help would be great :slight_smile:

1 Like

Please have a look at the Blender filesystem page of the documentation. There is an infobox, especially for this case.

Please notice: I am also no MAC user so I can’t test nor give any guarantee. Hope it helps.

locate the in finder

right mouse button and “show package content”

navigate to Contents/Resources/blenderversion/ and create a config directory there.

Then restart Blender and you can work in your portable installation. HTH


Thanks!!! Much appreciated :+1::grinning:

Sounds great in theory, but it doesn’t work, at least not for me on 10.14 Mohave. That was (and is) the approach I took based on Chipps original video. I opened package contents and placed an empty Config folder in there. But Blender cannot write to it - even after I give read/write permission to that series of folders (at the Content folder level, giving all folders under it permission).

Probably a good idea to submit a bug report. I’ve been hearing of other problems with Mac and Blender 2.8 as well. Submitting bug reports is the best and fastest way to get things resolved.

Have you tried to create a folder called 2.80 within MacOS and within that another one called config? That would give what the docs say.
In your screenshot I see:


If the docs are correct, then this can’t work. And it would be consistent with what we have on Windows and Linux (in relation to the executable).

1 Like

Ah - Ok did that, now it seems to run. Although it is picking up all my old settings too. I’ll go back to the video now and start over. Thanks!

1 Like

At least you can work again. Sry I can’t be of more help since I don’t own a Mac myself.

1 Like

When you create the config folder yourself you create a portable with your own settings. Otherwise, Blender reads what finds in $HOME/Library/Application Support/Blender, the common location for site-wide installation, i.e the same as %APPDATA% in windows…

Ok, having that info, I started the process all over again with today’s build. I even went into

Users⁩/iMacRiverSong⁩/⁨Library⁩/Application Support⁩/Blender/2.80/Config

and removed the current userprefs.blend to be safe. Then I created the portable folder in

What happened is that Blender STILL looks at the install config, not the portable one I made. You can see that I created the portable config file at 7:23 am. Shortly after I launched Blender and it wrote new userpref.blend to the file system config at 7:32 instead.


I’ve created a bug

I have that too

It doesn’t prevent me to run it portable…
it is created first time you run Blender in system (non-portable) mode.
So next question is: how do you run Blender?
Double click on the app file or run by command line?

EDIT: forget it, it’s the same

So it didn’t work for you? I was double clicking the blender icon from the applications folder.

Ah, sorry, I meant it’s the same for me if I run from app or command line…

So you are getting a user prefs created in your portable config folder?

Yes, because s.t. ago I run a Blender 2.80 without portable setup.
I just deleted it, and now it’s no more…

Tom, what if you rename the non portable Config folder to something else and then try running the portable version. Does that work?

Good idea - odd result. I did that, relaunched - took a bit longer to launch but clearly launched as a clean version (the user prefs were not loaded). I did not get an error. However, it has not added a user prefs to the new config folder that I created.

I added KitOps as an add on, set the display to 1.5 and started it again.

This time it loaded with those settings saved. But it has not saved them to the original user prefs where I changed the name - that file has not changed since 12:30 (couple hours ago). Yet again, there is no user prefs in that new config folder. Where it’s coming from is a mystery.

EDIT: Went back in and realized, it created a NEW config file in application support on it’s own. So it’s still reading that original directory.

Please document it as a bug. That would be helpful to all Mac users. You can now use the help menu to submit bugs.