How to cut off radius (rounded on one axis) corners?

Okay, I’m definitely a noob but I did quite a bit of Googling and I can’t find an answer.

I’m designing real world parts, not necessarily for 3D printing but for somewhat accurate ortho and 3D drawings.

I have a simple, flattened cube that I’ve resized to specific dimensions. I’ve put a hole in it by using a cylinder, then Modifier > Boolean > Difference > Apply.

Next, i want to radius the front two corners. I don’t want it “rounded”. In other words I want to keep the edges sharp.

I have tried adding a Bevel but I can’t get it to do what I want. In Edit mode, I’ve selected the two vertical edges. I’ve saved them as a group. I’ve tried all different combinations of the Bevel controls but the best it gives me is an asymmetrical radius. I need the radius to be constant.

If I create a new plane, it starts as a square and I can do shift-ctrl-B and get an interactive bevel that I can make exactly how I want. Then, I can extrude the top face and give the piece some thickness. I have to leave the plane square, or the bevel isn’t symmetrical. Finally, I can extrude the sides to get the overall dimensions I want.

But that seems like a backwards way to make things. How can I cut off parts and radius corners on existing objects?


Included is the object I’m trying to modify: mount-tab.blend (777 KB)

Can’t check your blend yet but when you are getting asymmetrical bevels first thing to look at is if you have applied the scaling of your model. (are the scale parameters in the N-panel all at 1?)

blender 2.74 has a superior bevel modifier in my opinion, it wont distort the mesh.

Just Checked, scale is apllied correctly, the problem is with the holding edges. Either lay then out perpindicular to your cut or get rid of them at all and you schould be good to go.

By the way when working with a bevel modifier it is often easier to work with bevel weights instead of vertex groups. Especialliy when you want to bevel edges instead of vertices. Here’s the first tutorial on that I could find:

You need to apply scale - while in object mode ctrl+a -> Scale. Bevel will work as you expect then. Geometry data(object data) and transforms(object) including scale are stored separately in Blender and apparently Blender applies transforms after bevel operation, so whatever scale values you see in the n panel or object tab under transform get applied on top of the bevel operation that’s why it seems asymmetrical.

Edit: Oh, OK, this is not the case here. Didn’t notice the file attached would have checked. My bad.

Getting a good bevel can have a lot to do with the geometry. In the initial blend file, the edges linking the cut hole to the outer part of the plane are such that when bevelling, it forces vertices to cross over. All I did was create some new ‘linking’ edges at a different angle and as you can see, I can get quite a large bevel without cross-over. Sometimes, you just have to play about a bit to get the result you want in this sort of situation.
Layer 10 has the modified tab, (I only edited the upper face, so you would need to create new edges on the lower face to produce the same result. Layer 20 has the object from layer 10 with the large bevel, as you can see, no cross-over. :slight_smile:


Common mistake to jump using booleans. It’s polygonal modeling and the structure is important. Boolean operations are more common in CAD, especially Solid Modeling, but with polygonal modeling the mesh structure is manipulated to get to the result. You’re supposed to do that with a workflow, but boolean operations don’t know how to build a proper structure for the new forms, it just adds and removes geometry so it’s possible to make the form.

By doing that, you’ve introduced problems in the mesh. For one it’s a modifier so it’s non-desctructive until you apply it, so no need to hurry with that. Then the resulting structure might not be suitable for neat bevels, and it also added n-gons (faces with more than 4 sides) that are concave. If there is a problem with automatic triangulation, there will be geometry problems, and n-gons can distort with normal UV unwrapping.

Example file didn’t have those. Also there are no edge groups, only vertex groups. If you put the vertices in a quadrilateral face in a group, it doesn’t only contain two edges but all four. In other words, shared edges get selected. Adding an edge loop in between or using edge bevel weight allows to bevel only the two edges.

Doable but it’s not fun to edit bad geometry. No one starts a marathon by first shooting themselves in the foot.

mount-tab2.blend (157 KB)

Hey Everyone,

First of all, I want to thank all of you for your responses. This really seems like a great forum!

I just finished reading all of the responses and while I don’t understand all of it immediately, I’ll go back and follow links and look up anything I don’t get right away.

Unfortunately, I guess I wasn’t clear enough in my original post. I don’t want to chamfer the hole, or do anything to the hole. I don’t really want a “bevel” either (in the carpentry sense). I want to radius the front 2 corners of the piece.

I’ve attached a second version of my file with a plane showing what I want. To radius the corners on the plane, I selected the 2 front vertices in edit mode, then I used ctrl-shift-B. I tried selecting the FOUR front vertices in my other piece but then ctrl-shift-B does really weird things, not what I want. —> mount-tab02.blend (780 KB)

So, I’m using Blender to design parts. I’m coming from a mechanical background. I won’t always know where the holes need to be until I fit the pieces and see how they line up. I won’t always know where I need rounded corners so a tab more easily fits into a slot in another piece.

Obviously I don’t want to shoot myself in the foot but what is the best way to cut holes and slots in pieces after they have been created?



Design and modeling is very different. Since you’re designing, the structure isn’t that important.

For that, could choose from many options. Booleans, BoolTool is a helpful addon for that. Curves if the design is mostly 2 dimensional, could also use vector a drawing program and import an .svg, which import as curves.

But don’t know what the problem with the bevel is, works just fine for me. Bevel (ctrl+B) is for edges, vertex bevel (ctrl+shift+B) is for vertices. Vertex bevel is in normal bevel options, it just has its own hotkey.

Use screenshots of the whole interface and/or other images to help you explain. Using quotes and UPPERCASING normal words is not making anything clear. Screenshots can be taken from Blender directly, ctrl+F3 to save a shot.


Thanks so much! I downloaded your video so I can step through it frame by frame. I saw a number of new things and I’m sure I will learn a lot! Good tip about using screenshots. I should have done that in the first place.

What program are you using to record your screen and also show the keyboard and mouse clicks?

I’m using SimpleScreenRecorder, hotkeys are shown with Screencast keys addon in Blender itself. It doesn’t come with Blender anymore because of some problems, and it doesn’t show all pressed keys.

I recorded the screen because that way I was able to quickly show visuals about the things I mentioned in the post. Bevel, how I did it, what settings I used, and that it rounded the corners uniformly on both sides (the first minute). The rest are just small examples of using boolean modifiers, which booltools help to manage, and how curves would behave in case those are something you could use. I copied the dimensions and placement from the original to give a reference point for what I’m making.

I don’t recommend trying to learn how to use those from that video, it’s not meant for that. BoolTool has examples on the addon page, and curves very likely need some actual tutorials. Here’s one