How to deactivate image blurring in blender?

I´m having some problems with images applyed at planes in blender. The image below explains well this problem.Someone told me which I could deactivate this feature in blender using python,making the image return to it original quality.Anyone know how is this python?

http://philosopher.soul.googlepages.com/low-quality.png/low-quality-full.jpg

A friend said this upon this problem:
"sorry i havn’t touched OpenGL in over 5 years, and I do not have the exact code for it, but in theory you could make any OGL call through the api:

Quote:
import Blender
from Blender.BGL import *
glEnable(GL_CULL_FACE)
glCullFace(GL_BACK)
the above is an example to cull backface

Quote:
TEXTURE_MIN_FILTER
TEXTURE_MAG_FILTER
Google for the syntax for the above two terms and you should be able to implement it into your own script. Use GL_NEAREST for a pixelated look."

another one:

"There is nothing you can do directly in blender to get rid of this ‘blurring’ It is caused by magnification that is applied to all texture by OpenGL.

However, with a simple python script, it is possible to turn off texture-magnification (and texture minification) by an OGL API call."

I would be gratefull for any help.

I’m working with some opengl right now. Nothing advanced, but it has to do with images on planes also.

I haven’t looked into this side of things using openGL, but you can set this manually. In the material/textures buttons for images, there are two settings, “interpolate” and “mipmap”, which you can turn off if you want the pixelated look. Setting these from Python is also possible, I believe.

Deactivating these features don´t work. I need to deactivate these texture magnification and mignification,and I don´t know how to write the code required for that.

If you are using the game engine, then it is just the Mipmapping. Go to the top, pull down the top bar, go to System and Open GL, In there on Right there is a button that says Mipmapping. I wouldn’t have a clue for rendering. sorry if this doesn’t help
.

Hmm… The mentioned buttons work for me, but only in rendering, not in the viewport.

Where do you need it? The viewport, the rendering, the Game engine?

I don’t know how to insert an opengl command into the viewport’s display loop, sorry.

turn off OSA

It´s for game engine,and deactivating mipmap don´t work too.

Oh, I was assuming rendering. In that case, I don’t really know anything. The GE is quite different from the non-realtime scripting.

Aren’t there some knowledgeable people in the GE forums?

I think MipMap is a texture option, on by default. just turn it off. see Texture buttons. http://wiki.blender.org/index.php/Manual/Image_Textures