How to disable box select through in object mode?

I tried to search for an answer, but found none. I’m using version 2.81. When I use box selection in object mode, it selects all objects behind an object even though I don’t have X-ray mode enabled. How do you box select only visible objects in object mode? (I’m using the industry compatible keymap, but I tested this using the default blender keymap and it works the same way.)

hmm … looks like that is the normal function, also find strange
https://docs.blender.org/manual/de/dev/interface/selecting.html

Yeah, I read that doc, but it looks like there isn’t a setting to disable this… Why didn’t they just make object mode selection the same way in edit mode?