How to disable Passive Rigid Bodies

Hi. I am creating an animation with rigid bodies and I am using a passive rb to stop the spheres from falling. I would like to turn off the passive rb at certain frame and let the spheres to fall.

The only thing that came to my mind so far was to create a shape key in my rigid passive body and scale it down. Did not work :

Is there anyway to it off? I did not find any option to desactivate it .

Thank you

well you can just move it away in one frame.

Because it returns to its place. The object is parented to an empty, but I really do not understand why that. is a limitation. I could share more information if you think it could help.

So what else is also parented to the empty and why? Well you can also keyframe the collections in the rigid body settings. Not sure if it works but it should

It sounds like that the rigid body physics are baked. Try deleting the bake. if it doesn’t work try enabling the “animated” options on the physic tab under Settings
image

Thank you, the animated is on and the physics not baked…

Did you keyframe the passive object? Make a keyframe before you move it and another after you move it. It should work.

As for shape keys, the active RB objects need to be changed to mesh shape type and have deforming option enabled - using mesh as shape will slow down the calculations.