How to don't let particles go outside a specific mesh?

Hi! Here is a project I am working on right now for christmas. Right now I am not so sure how to control the particles, which in this case is the lingonberry. I don’t want them to go outside the candlestick, as they do at the moment. I have tried the collision physics on the candlestick with no result. What could it be that I am not doing right? Thanks!


First of all, nice project. I think you mean outside the box right?

Thanks! Yes, exactly. Now I have tried with interpolated children, and that way it will not produce any children particles at all. When I have the simple children, it will produce children particles, but then they also go outside the box in that mode. An option would maybe be to not use children at all, but I think i still need them…