How to enable texture nodes (Cycles)

Hello everyone, maybe I’ts a stupid question, I try to search but I didn’t find any answers.

I’m trying to use texture nodes, but I can’t figure out how to enable them. I create a cube with a simple Cycles diffuse material, then i add an image texture (I triyed a generated UV grid and also an imported image texture), then I open the node editor and switch to texture nodes mode, type of data is set to object. If I try to add a new node (Shift-Tab), every node is disabled. There is no “use nodes” checkbox in the header. What am I doing wrong?

Thanks in advance!

Those texture nodes are Blender Internal texture nodes.
Just as Cycles can’t use BI materials, it can’t use BI textures. That’s why the whole texture node functionality is basically disabled while in Cycles Render mode. All texture modifications have to be done in Cycles’ shader node tree.

Oh, i had suspected that it was like that, thanks for the quick answer!