HOW TO ENABLE the new Dependency Graph in Blender?

Hello all,

I was wondering if someone would be kind enough to share a step by step instruction on enabling the the new depsgraph in Blender. I looked online, but could not figure out how to do it. I’m using Blender 2.5.

Thanks so much!


I dont know if I can be much help because I couldn’t quite figure out how to do it myself, there are some basic instructions available here:

Basically you’re supposed to pass the command line argument, “–enable-new-depsgraph”, but i couldn’t actually figure out how to do this D:

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

Thanks, Crocadillian, for your response! If someone could share how to run that command line argument, that would be most appreciated! Some of us are just modellers and animators, not coders… :slight_smile:

You need to start blender from the command line. To do this, on Windows open the program command-prompt (under Accessories) or select “Run” from the start-up menu. On Linux or Mac open the terminal window.

Then type in the location of blender (which will depend on where you installed blender and how your system is set up) followed by a space and then the command line arguments. On Windows it will be something like “C:\Program Files (x86)\Blender2.75\bin\blender.exe --enable-new-depsgraph”. On Linux you should be able to just type “blender --enable-new-depsgraph”.

Then hit the return key and blender should start with depsgraph enable. But be careful, it is disabled for a reason.

That shouldn’t be a reason not to know basic command line usage. It’s useful for all kinds of artist’s tasks, especially batch rendering. Here’s some guides to get you started:


More general:

So to use the “–enable-new-depsgraph” flag, you’d navigate to the blender executable and run, for example:

blender --enable-new-depsgraph

And Blender will fire up in the terminal window you have open, using the new depsgraph. If you want to start Blender normally, you just run without any flags


or if you want to render a file, you can use the -b flag (open in background, follow it up with the path to the file you want) and then the -f flag (render given frame) followed up the frame number:

blender -b /projects/foo/scenes/final_v5_for_real_this_time.blend -f 1

In windows you can use a shortcut in this case (a simple switch to enable this feature). In win7 this is the method:

Create a shortcut to blender.exe. Right click to open the shortcut’s Properties panel. Add the switch to the end of the target path found in the shortcut tab. Mind the space. There has to be a space between the path and the switch.

Mine looks something like this:

“C:\path to my blender folder\Blender-2.75-windows64\blender.exe” --enable-new-depsgraph

If you got it right it will start Blender and you will see “Using new dependency graph” on the first line in the Blender system console (Menu > Window > Toggle system console). You might want to rename that shortcut so you don’t forget what it does.

Party on.


Are You sure it’s blender.exe You shall use in Your shortcut…?

If I remember right…I have read You shall use the blender-app.exe to start Blender in Windows ?


Thank you J_the_Ninja for those incredibly helpful links! Yes, I was able to get it to work via the command line. I agree that command line knowledge is useful, as I did make a batch render script once that saved a lot hassle. I will share how to do that soon in a separate post. Interestingly, one youtube tutorial about batch rendering in Blender did “work” for a few non-render intensive files, but when I tried that same script on files that were 1 - 2 minutes per frame, it would always fail after completing 1 render. I found some additional code (on and, although I don’t know why, adding that script in made the long renders work.

Thank you LarryPhillips for that fantastic shortcut!! That really makes launching the new dependency graph very quick.

The good news is my shapekey now can drive another shapekey directly… the bad news is, all the driven shapekeys I had made for the character’s mouth are glitchy, even when they’re not supposed to be animated. This was caused by the limit location constraints on the bones (with custom shapes) that drove the shapekeys. Deleting the constraints fixed the glitching, however the playback fps shows alternating between 25 and 26 fps even though the fps is set to 24. No doubt there’s some bugs to be worked out, but the technology in the new depsgraph looks great!

EDIT: I just noticed the fps issue even with depsgraph disabled. Funny I didn’t notice that yesterday, but I assume it’s just a bug in 2.75. I am running the scene with simplify enabled.

Thanks again guys! :slight_smile:

Also, thanks very much Jordan001 for taking the time to repond! Greatly appreciated.

Well, that’s interesting. The shapekey drives the other shapekey accurately in real time, but if you set keyframes to animate the shapekey, then it won’t drive the other one! I’m going to try another technique until the issues can be worked out.

Thanks for explanation and links…:slight_smile:


Don’t assume anything. If you think you’ve come across a bug, report it. Worst case, it’s not a bug, but you find out why.

Thanks Fweeb for your reply.

for the linux guy’s i did without any problem very simple actually i use antergos an arch based distribution but i dont think that there wouldnt be any problem
open the terminal and search for the executable file in my case was " /usr/bin/blender " and add the --enable-new-depsgraph command so
the end result has to be “/usr/bin/blender --enable-new-depsgraph” and that’s all for the ones who download the tarball from the official website well just do the same thing run the executable file rom the terminal adding the command to enable it that’s it :slight_smile:

Thanks alexdmz for sharing that info for Linux users! :slight_smile:

no problem, now im looking for a way to disable it, as we all might know the new dependency graph still not production ready, thats why it isnt enable by default, sadly i got some bugs while working in blender withe the new dependency graph enabled and its kind of anoying me at the moment :no:

Wish I could help you with that! On Windows, the dependency graph didn’t stay enabled when launched via the command line, but it would stay enabled via Larry Phillips helpful shortcut in post #7. All I had to do was delete the “–enable-new-depsgraph” addition after the path and it returned to normal.