How To Enable Vertex Color Mode in Grease Pencil? (v2.91)

When I switched to vertex color mode to fill in some shapes, it appeared to stay in material mode because the colors would only change if I changed the material color, but not the vertex color. Whether I was messing with stroke or fill, I couldn’t change the vertex color.
I tried again in a new document and vertex color mode was working, but when I went back to the original file I was working on, the problem persisted which makes my think I accidentally turned on some feature that would prevent me from using vertex color. If so, how can I disable this feature?
Please forgive me if this has some obvious fix. I am very new to blender (as in I just started using it today).