How to fix this issue?

Hi guys,
I have a shading issue as shown in the pic. I am sure it is probably related to the typology. However, I tried a lot of things and nothing seem to fix it. Can you guys help me?

Your problem is due to the edges created by the insert tool. If you add another loop below where the bend is on that front side to put some space between the top of the slot and the start of the bend of the front face it will not show up.

I have tried your solution but didn’t work. It is so frustrating :smiley:
Thanks for your reply :slight_smile:

You’re problem is that you don’t have enough subdivisions to support the curvature. Crank up the subdivision modifier up a notch, then apply it (yes I know you don’t want to do that but do it anyway), then try to do the inset face. It will work then

Watch this

It should work. This is not a difficult problem.

Can we see your blend file?

Here is my blender file. robot_toaster.blend (1.2 MB)

This face of yours is not flat. Make the same selection as i did, then scale it along the Y axses with a value of 0.

Then apply the solution that @Anthony_Forwood gave you, which is the right answer in this case.

As a side tips

try to simplify your topology a bit, you’re working with a lot of unnecessary edges.

1 Like

@FinalBarrage @Anthony_Forwood @9athooh
Thanks a lot. You guys are the best :smiley:

@FinalBarrage I am adding edges bcz I will add details. I will try to reduce the number of edges :slight_smile:

1 Like