How to format a USB flash stick? (help!)


(benstabler) #1

Hi guys,

I just bought a USB flash stick (256mb), the brand is “CosKin” but they’re probably some little asian brand… Bought from a Darty outlet in France.

It showed up fine, but when I tried to put files on it the little light went into hyperventilation and the PC froze up. Finally, I decided that as there was 0bytes used on the drive according to MS explorer, it might need formatting. I told it to format, and the bar went to 100% in about 20secs, but the light was still flashing. I got bored and pulled it out.

So, now it shows to be an 8meg drive formatted as RAW, and every time I click on it it asks to be formatted. Of course, this doesnt work. When I view its disk usage, it says 0bytes of 0bytes.

After searching on the net for hours, it seems no-one in the world has ever had this problem. The general solution, though, is to format its MBR and then reformat it. Of course, to do this you use FDISK /MBR or /CMBR, in Dos. But flash sticks are USB and dont work in Dos.

Any ideas? (I tried doing it in puppy linux too, but that didnt seem to work either.)

Thanks,
lightning


(WhiteBoy) #2

You probably killed the poor thing. Unplugging a device while it’s still churning away is a very dangerous thing to do.

My guess is that you’ll have to replace it. And if the new one also freezes your machine, try to find some updated drivers before you do anything drastic.


(benstabler) #3

Hmm… that was what I was afraid of…

As for the drivers, I am running XP and there werent any provided/on the website (for XP- the install program wouldnt let me run it). I hope this is not the problem!


(yellow) #4

http://www.bay-wolf.com/usbmemstick.htm

FAQ http://www.usbmemory.com or their support might help

bye


(mzungu) #5

If you’re able to see the device in XP’s Disk Management tool (Control Panel --> Admin Tools --> Comp Mgr --> Disk Mgr) you may be able to manipulate it from there… ?


(benstabler) #6

mzungo: Yes, I tried that, but there it showed up as 8mb also, and refused to format etc.

yellow: Hmm, the bay-wolf.com site was more about formatting the stick to boot, whereas I can’t get it to format at all :-? . The usbmemory.com site wasnt able to answer my question, but i’ve bookmarked it because their range of products looks great! Next time I buy a memory stick, it will be from them. I think I’ve learnt my lesson about buying from no-name memory manufacturers :wink:

Well, I’ve come to the conclusion that there is something fundamentally wrong with the memory stick, so I’m going to contact the manufacturer and see what they say.


(osxrules) #7

When I format a memory stick in OS X, it shows up in two parts: The drive itself and the partition format. I’ve heard people say they got free sticks from conferences with data on them and they came wth two partitions and no matter how they formatted the stick, they wouldn’t get all the space back. But they just had to format the drive itself then format the partition.

If XP somehow halted before it finished formatting the partition, maybe it just made an 8MB partition. It will probably stay that way until you format the drive.


(benstabler) #8

Osx: the problem is that I cant format the drive, it just wont let me do it. Although it shows up as an 8mb stick, when I look at its space usage it says 0bytes free of 0bytes…


(osxrules) #9

I wonder if you can only format it with certain software. When I format a DVD-Ram disc in Toast (Mac equivalent of Easy Media Creator), it formats it in such a way that OS X says there is no free space. But, if I format using OS X’s disk utility, it works like a hard drive.

There are 3rd party flash erasers around somewhere.

I also came across this page. I don’t know if it will be of any help:

http://pchere.blogspot.com/2005/08/fix-format-usb-flash-drives.html

or maybe this: