How to get compositor to not show through the mesh of my object?

The problem I am encountering is that I com-posited a great lighting effect for my object, but when I change the angle from which I render it shows through the mesh. It’s messing up the render’s I am trying to achieve.

On top of that, adding any additional lighting isn’t showing up in the render. Only the light coming from the object used in the compositor.

Have I done anything wrong? Is there some button I haven’t checked?

The problem can be seen here:

It’s having the lights show through the sides of the pod. They should be funneled blocked from doing that.

upload the .blend if you want any chance at help for such a complicated problem

Here. Textures are broken though. Thanks much!

I fixed it, .blend incoming along with description


Alright, a couple of things. It was right to have your spotlights on a separate render layer. However, you also need to put the ship on a separate render layer and set it on the spotlight layer so that the spotlight layer alpha is masked by the ship layer. It’s the little buttons just below the layer buttons in the layer panel. On top of that, your method for blurring was wayyyy too complicated and would only cause you headaches with different camera angles down the road. I completely rebuilt the compositing to reflect this. You can add on top of these settings whatever you’d like now.

In the world panel I saw that you had Ambient Occlusion settings set to 3 samples. This really doesn’t do anything visibly useful except greatly increase your render times. I went ahead and set this to one. You may want to consider lowering the error a bit, but for this scene it doesn’t appear to be necessary. I also always advise turning pixel cache on, as it is a huge time saver. I also turned on falloff to give a more physically plausible effect to the bounce lighting and AO.

The only other thing I did was I took the liberty of adding two spot lamps parented to the emitting objects to help sell the volumetric effect. This was just personal preference, feel free to do with this what you will haha.

I love the model, very cool. My only suggestion would be to change the emiting spheres to slightly convex lenses coming out of the front of the cowlings as it would help with the compositing effect from the side and help to lower your AO calculation times in the long run.

Anyway, let me know if you need any other help here. Happy Blending!

EDIT: Oh, one more thing! The reason adding lighting wasn’t working was because you were only adding it to one layer, the spotlight layer. You need to make sure that lamps are on all layers that you wish to use them on. You can do this by clicking your lamps, pressing ‘M’, and then shift clicking every layer you wish to be lit by that lamp. I also parented the camera to an empty for easier panning of the camera around the ship. If you find the camera isn’t behaving some way you’d like it to, this is probably why.

I can’t thank you enough for this. I was at a complete loss. This is a massive massive help. Unfortunately for me I can see I’m missing out on a lot of features that would really help make the process easier. But you went even further and helped simplify my scene which is downright awesome. I think I’ll import the model and try to re-apply the textures. Thanks so much again.

If you don’t mind, I think you may get more questions later. I’m still learning a lot. :smiley:

Uploaded one with textures working for you to see. Not much of a difference. But it’s still cool!

Very cool looking! And yeah, feel free to shoot me a private message if you have any other questions.