How to get light through a surface?

https://pixabay.com/photos/nature-water-ocean-sea-underwater-2609434/
I’m trying to lit a wavy plane from behind in Eevee like in the picture above, but it doesn’t work. I thought all the settings for a common glass setup will be enough (transmission, IOR and the render settings), but the lit face of the plane doesn’t transmit any color or shining to the other face.
The environment lighting/texture are disabled to observe the pure light better:


The other face of the plane where the camera is placed is unaffected by light and looks dark. I need the plane to look like a lampshade, how can I do this in Eevee?

Have you set a blend mode and shadow mode for the material in properties/material/settings? Not “opaque”.

Yes, but I barely get a trace of specular passing through and not much more, not what I was expecting. Here’s another example, light behind glass, same render in Cycles and Eeevee:


I know there are differences between the two rendering engines, but this is too much. I must be doing something wrong, maybe the shader for Eevee should be completely different?

My refracting cubes aren’t acting like that:

Do you have a file? Specifics about rendering settings, material settings, and material nodes are probably necessary to figure out your problems and to what extent they can be addressed.

Sure, here’s the file:
glass-cube.blend (1.7 MB)

Is this on?

Change the shadow mode of the cube to “none” or to “alpha hashed”.

Yep.

But it looks even worse without the shadows, more like opaque glass…


I’d like to see the refraction of the other faces like in the Cycles render. Maybe it’s just not possible in Eevee?

The reason you don’t get “specular passing through” is because the cube blocks the light. If you turn the shadows off, the cube won’t block the light. I’m not sure what your ultimate goal is, but if you want to render in Eevee and have specular passing through something glass-like, you need to turn the shadows off.

The internal reflections? No, that’s not possible in Eevee.