How to get rid of Alpha borders...help!

Hello.
Ive mapped an image texture (.png) to one face of a rectangular object.

I created the texture in Inkscape, it has text and simple shapes.

My problem is, all the text and shapes show a white border around each one in the Blender render. Ive tried everything to remove these. Changed all strokes to 0 alpha (the background is also alpha), brought into GIMP to remove any ‘transparent’ borders (strokes) but to no avail. These white borders do not show up in either Inkscape of GIMP so Im thinking its a Blender thing.
Has anybody else had this problem?
Cheers, Matt.

Attachments


You have to enable PreMul (pre-multiply) for the texture in question.

Thanks for the advice Atom.

However, when I click that button (in the buttons menu) and re-render, it remains the same except the background is now black…

Obviously I’m doing something wrong, can you give me a heads up?

Cheers, Matt.

I’m a nobhead.
You meant of course the premul button in the texture panel which works a treat.
You are a genius and I am a fool…

Cheers! Matt.