How to get rid of the smoothing around the edges of a sprite texture?

I need help with getting rid of the smoothing around the edges of a sprite.
If the sprite is scaled down it creates this outline around the edges.
Is there a way how to turn off the smoothing of the texture?

I’m already using this:

from bge import render
render.setMipmapping(render.RAS_MIPMAP_NONE)


alpha clip id say. using material nodes gives further control over how much it clips. add a greater than math between the alpha sockets.

1 Like

you need use alpha-clip setup in material setting or use nodes - color ramp connect in alpha in output node and connect alpha mask image or use alpha mask texture (black and white) for clipping noize

1 Like

Thank you, this works exactly like I wanted.