How to get rid of the vertical banding on my sphere?

So im trying out some materials with adaptive subdivision…

Im using a material from Quixel and it’s supposed to look like this

Im trying to replicate this sphere…but im not getting the same smoothness

you can clearly see vertical banding… and im not sure how to get rid of this…

  • i created a sphere and subdivided it
  • added the material (8k)
  • put a subsurf modifier on it with adaptive on (0.5 dicing)
  • added an extra subsurf
  • set the shading to smooth

Any advise is welcome…thanks!

Hi, this could be a shot in the dark but your scaling is deferent then the original image,
check what it looks like when you have the same amount of groves.

Thank you for your answer…but that didnt help…
Here’s the file in case anybody wants to have a look

You didn’t include the texture but I had one that I could use…
I changed a few settings and turned on Auto Smooth Normals…delegated and re-added the Subdivision Modifiers…added an AO node to your mix…
Looking at your image I think some of the problems might be in either the Normal, the Roughness, and or the displacement…If you look carefully you can see the same thing happening in the Quixel version though it is not as pronounced or as obvious.
Also, I think if you check you have the adaptive subdivision set to Simple…switch to Catmull

I don’t get anything but the bad geometry on the UV sphere, at the top ( always happens without a few loop cuts there) and no banding as you are getting…
I really do think that one problem is what @digitvisions said, in the texture Coordinate and mapping, as scaling down will reduce some of that…

Just checked another thing, disable the second subdivision modifier and you will get better results…
With the second Sub Modifier…


and with it disabled…

It’s still there as the mesh is fairly low-poly … but not nearly as bad…

Just a thought, this might be an intentional part of the texture as if the planks are roughly cut and have not been sanded down.
RSEhlers is right that the same banding is in the Quixel original, yours is scaled up.