How to get rid of these horrible droplets on Eevee?

Hello friends from the best community on the planet! I followed this cool tutorial by @Zacharias_Reinhardt from CG Boost. However when rendering with the Eevee engine, the water droplets turned black, this result was far out of expectations… I followed step by step, with only a few general differences (the layout and intensity of light I used was not identical to what the tutorial did) but I got to this strange effect.

If there is something that I suspect that caused this, it is that in the settings of Eevee 2.80, in the tutorial changed the method of shadows from ESM to VSM. However in my Blender 2.81, there were no such options. It seems that Blender changed his algorithm, That’s right?

Is the problem with the amount (intensity) of light? Maybe is it in the settings of “Screen Space Reflections”? Could some tweaks to the shader nodes solve it? (I tried to adjust the shaders but it was not very intuitive for me to deal with these little refractions and shadows).

SECOND PROBLEM: Look at that strange artifact, a very wide band of horizontal light is coming out from the side of the bowl. It looks like some kind of reflection coming from the copper-alike material. That shouldn’t be there… what happened?


Thank you all for the patience, good manners and attention you always give to beginners on this forum. Greetings! (Follow me on instagram)

Did you enable this setting in the Render Properties tab?

If you do not want to share the entire scene to be analyzed by other users, in a new collection you add a sphere to the scene and add apple material to it. You delete the rest of the objects that you don’t want to share and save the .blend file with a different name. Share here that new .blend file with problematic material and lighting used.

@unyxium this was not the problem, this setting is enabled.
@YAFU thanks you, i will prepare the file and post within a few minutes.

This is my file with the mentioned problem(s) for anyone to analyse it. Thanks in advance!
DOWNLOAD - Filebin

Here the true solution:

You look in Blender manual about which features are supported for “light path” node in Eevee. You try to configure “Agua” material in this way for example:

Another disadvantage vs Cycles is that Eevee does not support Caustics. You can search in google if you find different ways to fake caustics in Eevee

According to the manual “Light paths/Is shadow ray” should work with Eevee:

Hi. You see here below in “Light Path” item:

According to the note, this works in Eevee only under certain circumstances just to try to achieve some compatibility with Cycles. In any case someone could try to report the problem to get out of doubt.

Turning off “Screen Space Refraction” for the material touched by the droplets seems to work …

That is true, I had not paid attention on Apple material. This is a limitation of Eevee for refraction:

Thanks @Ruwo it totally solved, thanks for doing the trick! And thanks you both for the explanation. Now I still fight with the second problem, wich is this light leaking here. Any tips?

What is your graphics card? AMD?

Yes. My graphic card is the Vega 11, wich is integrated to the Ryzen 5 3400G processor (APU). Maybe wait for new drivers and next Blender version? I will try to render it in my old notebook and see if this flare disappears (intel graphics)…

EDIT: with intel graphics it looks that is impossible to render on eevee.

That kind of artifacts appear with AMD cards, especially in large output resolutions. You read this thread, there is a report about it:

Thanks you all. Thread closed. :blush: :pray:

Please, check again @Ruwo answer as the Solution. This is more appropriate according to the theme and title of the thread.

Mmm, apparently it is possible to check more than one answer as a solution. I think it was not possible before.

I marked “solution” for both. It looks that I am not limited to choose only one answer as “solution”. But I will leave only Ruwo answer because it should be the first to be shown when a new person opens the thread.

Today I rendered it again and these artifacts are simply gone. Notice that there was a light coming out of the side of the bow, and there was a ghost above each leaf. Today it was enough to render and these defects disappeared. Thumbs up to AMD driver developers and to Blender 2.82!