How to get smooth fur with hair particles?

I’m trying to achieve smooth fur, here’s what I got so far: https://drive.google.com/file/d/1a8cuWgL_FNOrJtor9ScFk27MFn6oEUH_/view?usp=drivesdk
Fur looks kinda dirty, with dark spots and doesn’t blend with skin (hair uses 2x brighter color and still looks darker than skin)
Material and particles setups:


Hair1

Hair3
The closest image to what I want:

I want something similar to this, with nice blending with skin (and it’s not just material with normal map, you can see hair particles). I know that it was created in blender, so there’s should be a way

I’d try with principled hair shader for hair.

Principled hair doesn’t really give color control, it’s for things like brown/white/ginger human hair. I’ve tried it

Well, I think it gives control over everything, though it’s not very easy to use/understand, also using children can cause some problems like light/dark hair clumps :stuck_out_tongue:

Like with my bear render. I’ve been modifying this shader settings for hours, days. Finally got what I wanted. With that shader alone. :smiley:

Also, I think color control is quite okay, pardon my combing skills, especially the fragment where it looks like sticks are pointing out of the sphere xP that was the first plane not turned off :P:


/edit: that’s of course direct coloring, not a redhead. Just wanted to pick a similar color to example one.

some more random colours without tweaking:

1 Like

Wow, is this really rendered with principled hair?
Guess I have to spend more time learning this shader

Give this a read: https://docs.blender.org/manual/en/latest/render/cycles/nodes/types/shaders/hair_principled.html

Will tell you all you need to know for Principled Hair node. I’ve been using it on my current project, and It’s great honestly!

1 Like

I kinda found workaround with this shader. Actual color is much brighter than desired color in node, so you need to pick darker colors. Also actual color sharply changes to saturated when node color is nearly in the end of pallette, that’s strange

Here’s with default settings, only coat and color changed.

What did I do wrong? It became even worse

Material that I used
Material

Set coat to 1 and leave roughnesses at default.

Completely the same result. I also tried to disable kink in children settings, but dark spots are still there

I’ll need a .blend to try it myself

IMHO you need way more hair to cover her completely, and then play with the aspect, right now hair is visually fighting with the model surface, so it’s not pretty.

1 Like

Well, you have set minimal amount of bounces. Look at the difference of your bounces vs 16 bounces:



Of course it pumped up render times. I’ve changed sampling pattern from sobol to correlated multi-jitter, it increases render times a tiny bit but noise levels are much lower. Light Threshold to 0.1, filter glossy 0.1, clamp indirect 10.

2 Likes

I like to dig into stuff when something is not working like I expect it to, so I did for the build and render times here.

Body hair - it’s short and with no shape change. Change it’s render steps to 1 or even 0 to keep them straight. You have 10000 hair and 70 children each. That’s 700000 hair and with 5 steps it’s 2^5 subdivisions meaning 700000 x 32, and that’s just body hair.
Long hair - reduce render steps from 9 (such overkill! you do not use wave kink) to 5 (still overkill imho). If you want them to be smooth - use curves instead of paths.
Those two simple steps reduced ram usage from 26 gigabytes to 600 megabytes during scene building, and time from X minutes to seconds.

Here’s render with body steps 1, ponytail steps 4, bounces 5 and 8 for transparency and transmission, 512 samples. [paused, i go to sleep, but will post it tomorrow]

1 Like

Wow, I can’t remember when I changed bounce values. I thought it was default 0

Thanks, but even with your optimizations, hair steps - 3, fur steps - 0 building BVH still makes my PC freeze, so it’s not very important

So where do you render it? Because after doing that render times are going down a million times.

0 bounces means no raytracing, so it would be pointless to use cycles. You could use blender internal :stuck_out_tongue_winking_eye:

Here’s the image:

1 Like

It’s not even about render time, PC can’t even build scene. I’m rendering on 6 years old laptop with quad-core AMD and 4 gb ram, without any GPU. I know that it’s hard to imagine worse machine for rendering scenes with hair, but here we are :upside_down_face:

Well, I mixed up it with something. I know there’s something about bounce, where you could put 0 and it would mean unlimited

Nonetheless, check build times on laptop before and after changes. Difference is huge. Render times too.