How to give the ocean modifier thickness?

Hello,

I’m from from the netherlands and if my english isnt very good im sorry. I’m working on it.

But im trying to animate a section view of a dike in blender.
With water grass and everything only one problem
I can’t give the ocean modifier any thickness like if its animated in a glass box. I tried the fluid simulator but i only need the surface to be animated. Something like this image: http://www.innovatielocaties.nl/topics/innovatielocaties/veiligheid/rijke_dijk/_afbeelding_1__figuur__dwarsdoorsnede_dijklichaam_klein.jpg. but only the waves need to be animated. does anyone knows how to animate something like that?

Thanks a lot!

Danny

you can use a solidify modifier in your ocean object to have the water surface with a bit thickness… for the smooth limits problem, just add an edge split modifier on top.

This will not, however, give any volumetry to your water, so you’ll probably need another object to represent the water below surface.
For this, you can duplicate your ocean, and delete the solidify from this copy, and add a cube to the scene, with a boolean modifier in it, set to intersect your duplicated ocean. (this ocean can be placed in a hidden layer, or set to unrenderable)

Thanks!

the boolean modifier did the job! i added the boolean modifier to the ocean and intersect with a cube. now i don’t need to add
2 oceans. it worked well! and i can also animate it;)


now im trying to get rid of these strange lines on the side of water haha…


those lines are the other side of your object, refracted through the object. This is what it’s suppose to happen when you have a glass/water object like that.

For a less realistic material, you should experiment mixing a Transparent and a Glossy.

Yeah i fixed it 10 seconds after posting…

Just played a little with the roughness and IOR

But thanks for your help it looks a lot better now!
(not finished just a test render…)


Hi guys,
I tried to reproduce the same effect, but when i apply the boolean, i don’t get the depth…
What i did wrong?

Hi benzor,

setting the Boolean modifier setting “solver” to “Carve” should do the trick. (at least it did for me :slight_smile: )

I tried this option, but, it’s not morking for me…

That is strange… maybe your cube is bigger than the ocean. Have you tried a smaller cube?

1 Like

That’s right!
it worked with a smaller cube.
Thank you Helge

1 Like

I’m glad it did. Have fun :slight_smile:

1 Like

If you bake the ocean you could select the edge and add the vertices to a group and than shrinkwrap the edge to the plane beneath. Just a suggestion.

I am a newbie to blender and am trying to do this in blender 2.8…and struggling!

So I have added an ocean modifier to the default cube, then added a second cube, resized it to be slightly smaller than the ocean plane in X & Y and extended above and below in Z. I then added a boolean modifier to the ocean plane, set to Intersect, and selected the second cube.

What I want to do is to remove the faces above the ocean and then apply a material to emulate water below the ocean (transparent, slightly blue, etc…).

I will want to add a seabed at some point and then animate the ocean (which I have figured out how to do by inserting keyframes against the time value in the ocean modifier).

Net result is to create a cross section of a patch of ocean and seabed.

What am I doing wrong? Has something changed in blender 2.8 that means I am missing a step or two?

Thanks for your help.

Simon