How to hide your lighting in background when rendering with shadow catcher?

Hello, I’m very new to Blender so this is probably a basic question. What I’m trying to do is I want to render my main object separately from the background so I can do the compositing later in photoshop. I’m a Maya user, so to my knowledge, the basic idea is to have shadowcatcher material applied to the background mesh so it will catch the shadow from the character without actually rendering the background. What confused me when I did test render, the lighting bleeded out into the background, instead of giving a clean cut out of the character with only the shadows on the bottom. Where did I go wrong ? Did I miss something ? I’m using Blender 3.0 for the reference.

Do you rendered the background object with shadow catcher and have a grey background color in the image now? Then you also have to enable Render Properties → Film → Transparent. To get a pure render of you foreground object with catched shadows on the background object and an not existing background (transparent).