How to ignore reflection of a object with emission

Hello,
as the topic says I made a studio in 3D with walls that have very low roughness. I made a plane that makes an emission. When I want to hide the plane with ray visibility, the emission albo disappears. Can I hide a plane with all it reflects on walls, but still emiting the light on my main object?

There are several ways to achive that.
You could make a shader that is invisible only for camera, but the simplest option would be “indirect only”

It works per collection, so all you need to do is put the plane in a seperate collection and mark indirect only in the outliner

Indirect only option is hidden by default, you can enable it when you click outliner’s filter icon
image

1 Like

I forgot that this option only works for cycles.
If you are using eevee you need to make a shader like that:
image
you also need to enable transparency by changing blend mode in the material settings