how to install add-ons and run scripts remotely via command line?


(Riptyde) #1

So I posted a similar topic in the “Technical Support” section but did not get very far - thanks to Zeealpal for what he was able to offer. I’m hoping I can get farther here.

here is what I am trying to do.

I will be using Amazon AWS servers to render an animation. However, I have scripts and add-ons that need to be used for that rendering - More so the scrips. I might be able to get away without the add-ons. Amazon AWS is command line only so I can’t install add-ons the normal way (manually using the gui) it needs to be done via CLI.

1 - Add-ons - Can an add-on be installed via command line and how would I go about it? I a have been looking around the web for a while and found very little that would be useful.

2 - Scripts - To run scripts I need the Auto-run Python scrips feature enabled.
According to this page (https://docs.blender.org/manual/es/dev/advanced/scripting/security.html) I should be able to use the -y or --enable-autoexec command to turn this feature on. It also says (at the bottom) that this would work for when open a regular (I presume GUI version) instance of blender.

So to test this I have run the command for blender (to open in gui so I can verify) followed by the one of the above commands but it does not work. Blender opens but the auto-run python scrips check box is still unchecked.

Here is what I typed (in Terminal I am at the directory for running blender)
On Windows - blender -y or blender --enable-autoexec
On Ubuntu - ./blender -y or ./blender --enable-autoexec.

Again, blender opens in gui in either case, but the auto-run feature is not enabled.

any ideas why this is not working or what I am doing wrong?


(Spirou4D) #2

Have you try to add this:
–python-expr ‘bpy.context.user_preferences.system.use_scripts_auto_execute=True’

to see if python run well?


(Riptyde) #3

Unfortunately that did not work either.


(Spirou4D) #4

So add this option:
–python-console

and when the console is open, type this :
bpy.context.user_preferences.system.use_scripts_a uto_execute=True
to see the answer in console too

If you don’t find a solution, contact Todd McIntosh On Google+ :
Creator of Brenda API. https://github.com/jamesyonan/brenda
https://www.blendernetwork.org/todd-mcintosh
He know very well Amazon AWS servers .


(Riptyde) #5

Thanks Spirou4D. I tried your method and still no go. i have also contacted Todd M and he has offered a few points that I need to try.

I was wondering if you could try running blender from the command line and try the -y or --enable-autoexec to see if it would enable the auto-run Python scripts feature.

If not, maybe there is a bug or something.