How to keep particle objects anchored to the parent mesh

Inspired by Graswald, I took a shot at making low budget Moss. Moss overlaying small boulder. And a granite ledge

so I created a small cluster of moss plants to use as an object in a particle system. And deriving their color from the moss imagery.

Which worked. Except that unlike hair, the moss object plants are floating about a foot (world scale) above the rock, and tthe granite ledge.

When I shorten the hair system (its based on hair and not emitter) the particles do recede back towards the parent mesh, but get smaller in size.

so to compensate I increased the object’s size. But which causes the moss plants to rise up again, hovering above the rock.

Moreover, the plants are in a chaotic array. Not facing outward in an orderly array from the particle mesh, but rather lying on their sides, upside down, etc. This isn’t an issue with hair.

Also, I attempted the same thing with pine needles. But which produced a Similar, disordered result. And it has nothing to do with random settings in children

Any advice on how to tame the moss. And maybe pine needles.

Attachments



And another of settings

Attachments


Solved it. Actually not certain the exact mechanics, bu … the fix was using another particle grass mesh where the plants behaved, positioned proper alignment with the underlying parent mesh.

So, I simply made a copy of the “ggod particle mesh” Then I un-parented it from the original, creating its own object. The “new” object mesh retained the good particle orientation.

Next I “Joined” the original particle moss object mesh to a particle grass mesh. And wallah!! … Moss galore appeared, and were well behaved. Then I simply deleted the grass particle system from the New Moss mesh.

the end.