How to keyframe texture mapping vector coordinates to make an animation

Hello there. I have a perfectly seamless texture I want to use to animate a river of lava flowing along a mesh which is a boring flat plane I subdivided and some curved bends towards the Y axis to make it interesting (if you watch it from TOP view). I managed to at least make the texture to move along the X axis by adjusting its vector location mapping within Nodes. This however only appears on the texture viewport.

I heard from a tutorial that if you press i while you hover over some Nodes you can at least store data like the mixing of two color shaders, the mix of two procedural textures and so on, but it doesn’t seem to work for the Mapping. When I press i while I increase the X location, I see the number-sockets turning “blue”, then when I move to a new frame to store a new keyframe with a different X location, the number-sockets are green until I press i, then they turn blue again (it might be other color for you because I’m using a different theme, but I thing the default colours are yellow and green). The keyframes are there but when I press play, the frames run but nothing happens at the viewport.

Any clues about this? Is there any different way to animate a single texture along an axis without the need to resort to a sequence and to store it with keyframes? :spin:

Found the problem. Lack of sleep and not using Rendered Mode to see the animation. Now it works, but too bad it doesn’t show the animation in Texture mode while playing the animation :confused:

How, and how again, did you solve it?!

Here is my setup. One texture, one animated mapping – no motion!


Frame 1, value 0:


Frame 250, value 100:


And the rest in between – the same.

HEEEELP !

@JamFX thanks! But the main project I work on does require nodded materials with animated texture space. The above example was just for illustrating purposes. Any ideas what’s wrong with it? Should it work like this at all?

Ok. I give up. I can’t animate it via mapping node, so I did it via Separate RGB, then math (add and multiply) and then Combine RGB. It works, but it’s ugly.

Is there a bugfix request for it already?


#bug #node #animation

Yes I tried it out in a variety of configurations it looks like a dependency bug to me! In rendered view if I manually drag the mapping value the render will show the new mapping, but as a keyframed value it will not update the render! Your workaround is good… something to remember. BTW this doesn’t work in development or stable.

You should bugpost it, but it’s a BI animation bug so probably there’s no one assigned to deal with them in particular… that area of Blender is not the most glamorous.
I notice when I right click on the mapping field in BI I can add a KF but not a driver, whereas in Cycles I can add adriver too, but Kf’ing works just fine in cycles.

Smalltroll’s video might have some clues but … 100 minutes! Can’t look at it for a while.

no no sorry my bad, your doing it wrong.

the node set up for your materials is only for combining materials, all the attributes you need to animate the texture are in the texture propertieswhat you need is the clouds texture that you are using for your river of lava and also a seperate material for your River bank". you use the bank material to mask out the area of your ground plane where you don’t want lava using the nodes. I would have to do some more research on the correct setup for your nodes, but i know there is a tutorial or two aout combinng materials in this way, though i havent seen one that includes the animation part, but again that is just the offset value. i’ll try get a tutorial up in the next day or two to show you how i would solve this issue.